HDOJ 2199 Can you solve this equation?(二分查找法)

Can you solve this equation?

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 
Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 
Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 
Sample Input
  
  
2 100 -4
 
Sample Output
  
  
1.6152 No solution!

 

#include<iostream>   //C++的头文件,包括输入输出
using namespace std;   //与上面一行搭配
#include<cmath>       //pow()函数的头文件 
double y(double x)
{
       return 8*pow(x,4.0) + 7*pow(x,3.0) + 2*pow(x,2.0 )+ 3*x+ 6;
}
int main()
{
    int T;
    double Y,m;
    scanf("%d",&T);
    while(T--)
    {
       scanf("%lf",&Y);
       if(y(0)<=Y&&y(100)>=Y)    //利用数学知识,已知的那个等式是个单调递增的函数,所以此处可以这么判断
       {
           double zuo=0,you=100;   //此小段是二分的利用
           while(you-zuo>1e-6)
           {
              m=(you+zuo)/2;    //每次分2,判断Y的所在
             
              if(Y-y(m)<0)
              {
                 you=m-1e-7;
              }
              else
                 zuo=m+1e-7;
           }
           printf("%.4lf\n",m);
       }
       else printf("No solution!\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值