B - Can you solve this equation?(简单二分)

Can you solve this equation?

Time limit 1000 ms Memory limit 32768 kB OS Windows


Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!


题意:

方程8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,x属于[0,100],输入Y,问是否存在这样的X满足上方程,若存在,输出X

解题思路:

直接对X进行二分就可以了,没什么好说的


Code:

#include <iostream>
#include <cmath>
#include <cstdio>
using namespace std;

const double EPS=1e-5;

double f(double x)
{
    return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;
}

double bs(double Y)
{
    double lo=0,hi=100,mid;
    while(lo<hi)
    {
        mid=(hi+lo)/2.0;
        if(fabs(Y-f(mid))<EPS)
            return mid;
        else if(f(mid)<Y)
            lo=mid;
        else
            hi=mid;
    }
    return -1;
}


int main()
{
    int n;
    cin>>n;
    while(n--)
    {
        double Y;
        cin>>Y;
        double ans=bs(Y);
        if(ans==-1)
            cout<<"No solution!"<<endl;
        else
            printf("%.4f\n",ans);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值