S - How far away ? HDU - 2586 (LCA)

There are n houses in the village and some bidirectional roads connecting them. Every day peole always like to ask like this “How far is it if I want to go from house A to house B”? Usually it hard to answer. But luckily int this village the answer is always unique, since the roads are built in the way that there is a unique simple path(“simple” means you can’t visit a place twice) between every two houses. Yout task is to answer all these curious people.
Input
First line is a single integer T(T<=10), indicating the number of test cases.
For each test case,in the first line there are two numbers n(2<=n<=40000) and m (1<=m<=200),the number of houses and the number of queries. The following n-1 lines each consisting three numbers i,j,k, separated bu a single space, meaning that there is a road connecting house i and house j,with length k(0<k<=40000).The houses are labeled from 1 to n.
Next m lines each has distinct integers i and j, you areato answer the distance between house i and house j.
Output
For each test case,output m lines. Each line represents the answer of the query. Output a bland line after each test case.
Sample Input
2
3 2
1 2 10
3 1 15
1 2
2 3

2 2
1 2 100
1 2
2 1
Sample Output
10
25
100
100

求一棵树上两点的最近距离,用找出他们两个点的LCA,用一个点的深度减去LCA的深度的值加上另一个点的深度减去LCA的深度的值 就是最近距离

#include<cstdio>
#include<algorithm>
#include<string>
#include<cstring>
#include<math.h>
#include<iostream>
#include<vector>
#include<set>
#include<stack>
#include<map>
#include<queue>
typedef unsigned long long ull;
typedef long long ll;
using namespace std;
const int N=4e+5;
const int prime=2333317;
const int INF=0x3f3f3f3f3f;
int n,k,k2,m;
int dis[N],head[N],head2[N],vis[N],lca[N],pre[N],cut[N];
struct node
{
    int v,next,w;
}edge[N*10];
struct Node
{
    int u,v,next,w;
}se[N*10];
struct www
{
    int x,y;
}qqq[N*10];
void init()
{
    memset(head2,-1,sizeof(head2));
    memset(head,-1,sizeof(head));
    memset(lca,0,sizeof(lca));
    memset(vis,0,sizeof(vis));
    memset(dis,0,sizeof(dis));
    for(int i=0;i<=n;i++)
        pre[i]=i;
    k=k2=0;
}
void add(int u,int v,int w)
{
    edge[k].v=v;
    edge[k].w=w;
    edge[k].next=head[u];
    head[u]=k++;
}
void add2(int u,int v,int w)
{
    se[k2].u=u;
    se[k2].v=v;
    se[k2].w=w;
    se[k2].next=head2[u];
    head2[u]=k2++;
}
int Find(int x)
{
    if(x!=pre[x])
        pre[x]=Find(pre[x]);
    return pre[x];
}
void join(int x,int y)
{
    int fx=Find(x);
    int fy=Find(y);
    if(fx!=fy)
        pre[fy]=fx;
}
void dfs(int u)
{
    pre[u]=u;
    vis[u]=1;
    for(int i=head[u];i!=-1;i=edge[i].next)
    {
        int v=edge[i].v;
        if(!vis[v])
        {
            dis[v]=dis[u]+edge[i].w;
            dfs(v);
            join(u,v);
        }
    }
    for(int i=head2[u];i!=-1;i=se[i].next)
    {
        int v=se[i].v;
        int w=se[i].w;
        if(vis[v])
        {
            int root=Find(v);
            lca[w]=root;
        }
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        init();
        scanf("%d%d",&n,&m);
        int x,y,q;
        for(int i=1;i<n;i++)
        {
            scanf("%d%d%d",&x,&y,&q);
            add(x,y,q);
            add(y,x,q);
        }
        for(int i=1;i<=m;i++)
        {
            scanf("%d%d",&x,&y);
            qqq[i].x=x;
            qqq[i].y=y;
            add2(x,y,i);
            add2(y,x,i);
        }
        dfs(1);
        for(int i=1;i<=m;i++)
        {
            printf("%d\n",dis[qqq[i].x]+dis[qqq[i].y]-2*dis[lca[i]]);
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值