A - On the Way

Time Limit: 2 sec / Memory Limit: 1024 MB

Score : 100 points

Problem Statement
There are three houses on a number line: House 1, 2 and 3, with coordinates A, B and C
, respectively. Print Yes if we pass the coordinate of House 3 on the straight way from House 1 to House 2 without making a detour, and print No otherwise.

Constraints0≤A,B,C≤100A, B and C are distinct integers.

Input
Input is given from Standard Input in the following format:A B C

Output
Print Yes if we pass the coordinate of House 3 on the straight way from House 1 to House 2 without making a detour, and print No otherwise.

Sample Input 1
3 8 5
Sample Output 1
Yes
We pass the coordinate
5
on the straight way from the house at coordinate
3
to the house at coordinate
8
.

Sample Input 2
7 3 1
Sample Output 2
No
Sample Input 3
10 2 4
Sample Output 3
Yes
Sample Input 4
31 41 59
Sample Output 4
No

就是看第三个数在不在第一个和第二个数之间

#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<string>
#include<ctime>
#include<cmath>
#include<iostream>
#include<algorithm>
#include<map>
#include<stack>
#include<queue>
#include<set>
#include<vector>
#define ll long long
#define dd double
using namespace std;

int main() {
	ll n, m, k;
	while (cin >> n >> m >> k) {
		ll t;
		if (m < n) {
			t = m;
			m = n;
			n = t;
		}
		if (k >= n && k <= m) {
			cout << "Yes" << endl;
		}
		else {
			cout << "No" << endl;
		}
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值