1018 Public Bike Management

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

The above figure illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S
​3
​​ , we have 2 different shortest paths:

PBMC -> S
​1
​​ -> S
​3
​​ . In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S
​1
​​ and then take 5 bikes to S
​3
​​ , so that both stations will be in perfect conditions.

PBMC -> S
​2
​​ -> S
​3
​​ . This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:
Each input file contains one test case. For each case, the first line contains 4 numbers: C
​max
​​ (≤100), always an even number, is the maximum capacity of each station; N (≤500), the total number of stations; S
​p
​​ , the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers C
​i
​​ (i=1,⋯,N) where each C
​i
​​ is the current number of bikes at S
​i
​​ respectively. Then M lines follow, each contains 3 numbers: S
​i
​​ , S
​j
​​ , and T
​ij
​​ which describe the time T
​ij
​​ taken to move betwen stations S
​i
​​ and S
​j
​​ . All the numbers in a line are separated by a space.

Output Specification:
For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0−>S
​1
​​ −>⋯−>S
​p
​​ . Finally after another space, output the number of bikes that we must take back to PBMC after the condition of S
​p
​​ is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge’s data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0

#include<iostream>
#include<vector>
#include<queue>
#include<cmath>
const int maxn =505;
const int INF =10000;
using namespace std;
int G[maxn][maxn],d[maxn],weight[maxn];
int mineed=INF,minremain=INF;
int C,N,M,S;
vector<int> pre[maxn];
vector<int> path,tempath;
bool vis[maxn]={false};
void dijkstra(int s){
	fill(d,d+maxn,INF);
	d[s]=0;
	for(int i=0;i<=N;i++){
		int u=-1,min=INF;
		for(int j=0;j<=N;j++){
			if(!vis[j] && d[j] < min){
				u=j;
				min=d[j];
			}
		}
		if(u == -1) return;
		vis[u] = true;
		for(int i=0;i<=N;i++){
			if(!vis[i] && G[u][i] <INF){
				if(d[u] + G[u][i] < d[i]){
					d[i] = d[u] + G[u][i];
					pre[i].clear();
					pre[i].push_back(u);
				}
				else if(d[u] + G[u][i] == d[i]) pre[i].push_back(u);
			}
		}
	}
}
void DFS(int v){
	if(v == 0){
		tempath.push_back(v);
		int need=0,remain=0;
		for(int i=tempath.size()-1;i>=0;i--){
			if(weight[tempath[i]] > 0){
				remain+=weight[tempath[i]];
			}else{
				if(remain > abs(weight[tempath[i]])) remain-=abs(weight[tempath[i]]) ;
				else{
					need+=abs(weight[tempath[i]]) - remain;
					remain=0;
				}
			}
		}
		if(need < mineed){
			mineed=need;
			minremain=remain;
			path=tempath;
		}else if(need == mineed && remain < minremain){
			minremain=remain;
			path=tempath;
		}
		tempath.pop_back();
		return;
	}
	tempath.push_back(v);
	for(int i=0;i<pre[v].size();i++){
		DFS(pre[v][i]);
	}
	tempath.pop_back();
}
int main(){
	cin>>C>>N>>S>>M	;	
	fill(G[0],G[0]+maxn*maxn,INF);
	for(int i=1;i<=N;i++) {
		cin>> weight[i];
		weight[i]-=C/2;
	}
	
	for(int i=0;i<M;i++){
		int x,y,z;
		cin>>x>>y>>z;
		G[x][y] = z ;
		G[y][x] = z ;
	}
	dijkstra(0);
	DFS(S);
	cout<<mineed<<' ';
	for(int i=path.size()-1;i>=0;i--)  
	      if(i) cout<<path[i]<<"->";
	      else cout<<path[i]<<' ';
	cout<<minremain;
	return 0;
} 

dijkstra+dfs
难点在于判断从PBMC拿走的数量和还回去的数量(题意)
还有对于我来说

重要代码

void DFS(int v){
	if(v == 0){
		tempath.push_back(v);
		int need=0,remain=0;
		for(int i=tempath.size()-1;i>=0;i--){
			if(weight[tempath[i]] > 0){
				remain+=weight[tempath[i]];
			}else{
				if(remain > abs(weight[tempath[i]])) remain-=abs(weight[tempath[i]]) ;
				else{
					need+=abs(weight[tempath[i]]) - remain;
					remain=0;
				}
			}
		}
		if(need < mineed){
			mineed=need;
			minremain=remain;
			path=tempath;
		}else if(need == mineed && remain < minremain){
			minremain=remain;
			path=tempath;
		}
		tempath.pop_back();
		return;
	}

for(int i=tempath.size()-1;i>=0;i–){
我到现在还不明白为什么要i>=0,我理解的时i>0,i == 0为PMBC数量没有或者不知道,
i==0的时候没必要算啊,但是不算有不对,头疼

这是我第一次写的,只有20分,毕竟题意没理解到位,我想的时要回借要么还,所以我只以还的数量为标尺,我刚开始也想到了还,借,但是有转眼一想没必要。。。就算我想到了还,借,但是我肯定会写i>0.而不是i>=0,我始终认为i==0的时候没必要算,因为weight[i] == 0,没必要算啊,而且按照题意,你是到PMBC去借或者拿,没必要看PBMC有多少啊,
啊啊啊啊啊啊啊啊啊,越想越头疼

#include<iostream>
#include<vector>
#include<queue>
#include<cmath>
const int maxn =505;
const int INF =10000;
using namespace std;
int G[maxn][maxn],d[maxn],weight[maxn];
int minnumber=INF;
int C,N,M,S;
vector<int> pre[maxn];
vector<int> path,tempath;
bool vis[maxn]={false};
bool flag = true;
void dijkstra(int s){
	fill(d,d+maxn,INF);
	d[s]=0;
	for(int i=0;i<=N;i++){
		int u=-1,min=INF;
		for(int j=0;j<=N;j++){
			if(!vis[j] && d[j] < min){
				u=j;
				min=d[j];
			}
		}
		if(u == -1) return;
		vis[u] = true;
		for(int i=0;i<=N;i++){
			if(!vis[i] && G[u][i] <INF){
				if(d[u] + G[u][i] < d[i]){
					d[i] = d[u] + G[u][i];
					pre[i].clear();
					pre[i].push_back(u);
				}
				else if(d[u] + G[u][i] == d[i]) pre[i].push_back(u);
			}
		}
	}
}
void DFS(int v){
	if(v == 0){
		tempath.push_back(v);
		int tempnumber=0;
		for(int i=tempath.size()-1;i>0;i--){
		    tempnumber+= weight[tempath[i]]-C/2 ;	
		}
		if(tempnumber > 0) flag=false;
		
		int t=abs(tempnumber);
		if( t < minnumber ){
			minnumber=t;
			path=tempath;
		}
		tempath.pop_back();
		return;
	}
	tempath.push_back(v);
	for(int i=0;i<pre[v].size();i++){
		DFS(pre[v][i]);
	}
	tempath.pop_back();
}
int main(){
	cin>>C>>N>>S>>M	;	
	fill(G[0],G[0]+maxn*maxn,INF);
	for(int i=1;i<=N;i++) cin>> weight[i];
	
	for(int i=0;i<M;i++){
		int x,y,z;
		cin>>x>>y>>z;
		G[x][y] = z ;
		G[y][x] = z ;
	}
	dijkstra(0);
	DFS(S);
	
	if(flag)  cout<<minnumber<<' ';
	else cout<<'0'<<' ';
	
	for(int i=path.size()-1;i>=0;i--)  
	      if(i) cout<<path[i]<<"->";
	      else cout<<path[i]<<' ';
	if(flag)  cout<<'0';
	else cout<<minnumber;
	return 0;
} 

模板还是不是很熟练,写了40分钟,有一个粗心的小错误找了1个小时,,吐血,然后1个小时思考 题意+为什么要i==0 脑壳疼啊

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值