POJ 1151 Atlantis 线段树扫描线

题目

Description

There are several ancient Greek texts that contain descriptions of the fabled island Atlantis. Some of these texts even include maps of parts of the island. But unfortunately, these maps describe different regions of Atlantis. Your friend Bill has to know the total area for which maps exist. You (unwisely) volunteered to write a program that calculates this quantity.

Input

The input consists of several test cases. Each test case starts with a line containing a single integer n (1 <= n <= 100) of available maps. The n following lines describe one map each. Each of these lines contains four numbers x1;y1;x2;y2 (0 <= x1 < x2 <= 100000;0 <= y1 < y2 <= 100000), not necessarily integers. The values (x1; y1) and (x2;y2) are the coordinates of the top-left resp. bottom-right corner of the mapped area.
The input file is terminated by a line containing a single 0. Don’t process it.

Output

For each test case, your program should output one section. The first line of each section must be “Test case #k”, where k is the number of the test case (starting with 1). The second one must be “Total explored area: a”, where a is the total explored area (i.e. the area of the union of all rectangles in this test case), printed exact to two digits to the right of the decimal point.
Output a blank line after each test case.

Sample Input

2
10 10 20 20
15 15 25 25.5
0

Sample Output

Test case #1
Total explored area: 180.00 

分析

扫描线裸题。写出来就是为了水博客
对每一个矩形,将其划为两条平行的线段,横坐标分别为 x 1 , x 2 x1, x2 x1,x2, 纵坐标均为 ( y 1 , y 2 ) (y1,y2) (y1,y2),权值分别为1,-1。扫描过程中,两条线段先后将矩形加入和踢出范围。
这里由于前后线段的纵坐标区间是完全相等的,所以减小时可以直接进行和增加一样的修改。于是有以下方法:
开一个线段树,每个节点保存该区间被覆盖的长度和该节点在区间修改时被整体覆盖的次数。只要覆盖次数大于0,说明该区间被整体覆盖过,长度即为该区间的长度。否则,长度即为两个子区间的覆盖长度之和。每次查询并update即可。
由于这题数据不是很强,x不进行去重也能过。
上代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
#include <functional>
using namespace std;

const int maxn = 510*2;
struct node{
	int cnt;
	double len;
} tree[maxn*8];
struct lne{
	int val;
	double x, d, u;
	int s, e;
	bool operator < (const lne &oth) const
	{return x < oth.x;}
}l[maxn];
double ally[maxn];
int n, m;

void build(int l, int r, int dex)
{
	tree[dex].cnt = 0; tree[dex].len = 0;
	if(l != r){
		int mid = (l+r)>>1;
		build(l, mid, dex*2), build(mid+1, r, dex*2+1);
	}
}
void update(int l, int r, int dex, int x, int y, int val)
{
	if(l>= x && r<= y)
		tree[dex].cnt += val;
	else if(l > y || r < x) return;
	else{
		int mid = (l+r)>>1;
		update(l, mid, dex*2, x, y, val), update(mid+1, r, dex*2+1, x, y, val);
	}
	if(tree[dex].cnt > 0) tree[dex].len = ally[r+1] - ally[l];
	else tree[dex].len = (l==r?0:tree[dex*2].len+tree[dex*2+1].len);	
}

void solve(int cnt)
{
	double res = 0;
	double x1, x2, y1, y2;
	for(int i = 1; i <= n; i++){
		scanf("%lf%lf%lf%lf", &x1, &y1, &x2, &y2);
		l[i*2-1].x = x1, l[i*2-1].val = 1;
		l[i*2].x = x2, l[i*2].val = -1;
		l[i*2-1].u = l[2*i].u = y2, l[2*i-1].d = l[2*i].d = y1;
		ally[2*i-1] = y1, ally[2*i] = y2;
	}
	sort(ally+1, ally+1+2*n);
	m = unique(ally+1, ally+1+2*n) - ally -1;
	for(int i = 1; i <= n; i++){
		l[i*2-1].s = lower_bound(ally+1, ally+1+m, l[i*2-1].d)-ally;
		l[i*2-1].e = lower_bound(ally+1, ally+1+m, l[2*i-1].u)-ally;
		l[i*2].s = l[i*2-1].s, l[2*i].e = l[i*2-1].e;
	}
	build(1, m-1, 1);
	sort(l+1, l+1+2*n);
	update(1, m-1, 1, l[1].s, l[1].e-1, l[1].val);
	for(int i = 2; i <= 2*n; i++){
		res += tree[1].len*(l[i].x - l[i-1].x); 
		update(1, m-1, 1, l[i].s, l[i].e-1, l[i].val);
	}
	printf("Test case #%d\nTotal explored area: %.2f\n\n", cnt, res);
}

int main()
{
	int cnt = 1;
	while(scanf("%d", &n), n) solve(cnt++);
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值