HDU 5067 - Harry And Dig MachineTSP问题

题目链接:HDU 5067

题目

Problem Description

As we all know, Harry Porter learns magic at Hogwarts School. However, learning magical knowledge alone is insufficient to become a great magician. Sometimes, Harry also has to gain knowledge from other certain subjects, such as language, mathematics, English, and even algorithm.
Dumbledore, the headmaster of Hogwarts, is planning to construct a new teaching building in his school. The area he selects can be considered as an n*m grid, some (but no more than ten) cells of which might contain stones. We should remove the stones there in order to save place for the teaching building. However, the stones might be useful, so we just move them to the top-left cell. Taking it into account that Harry learned how to operate dig machine in Lanxiang School several years ago, Dumbledore decides to let him do this job and wants it done as quickly as possible. Harry needs one unit time to move his dig machine from one cell to the adjacent one. Yet skilled as he is, it takes no time for him to move stones into or out of the dig machine, which is big enough to carry infinite stones. Given Harry and his dig machine at the top-left cell in the beginning, if he wants to optimize his work, what is the minimal time Harry needs to finish it?

Input

They are sever test cases, you should process to the end of file.
For each test case, there are two integers n and m.(1≤n,m≤50).
The next n line, each line contains m integer. The j-th number of ith line a[i][j] means there are a[i][j] stones on the jth cell of the ith line.( 0≤a[i][j]≤100 , and no more than 10 of a[i][j] will be positive integer).

Output

For each test case, just output one line that contains an integer indicate the minimal time that Harry can finish his job.

Sample Input

3 3
0 0 0
0 100 0
0 0 0
2 2
1 1
1 1

Sample Output

4
4

题目大意

tsp裸题,就是给你一张图,其中有不超过10个点是需要经过的的点,问你把这些点都走一遍再回到原点(1,1)需要的最短路径。
很简单的tsp,只要记得处理只有出发点一个必经点的特殊情况即可。
上代码:

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define maxn 12
int abs(int x) { return x > 0 ? x : -x; }

const int INF = 1e8;

int dp[maxn][(1 << 11) + 5];
int dis[maxn][maxn];

struct dot {
	int x, y;
} d[maxn];

int n, m;
void init(int len)
{
	for (int i = 0; i <= len; i++)
		for (int j = 0; j < (1 << (len + 1)); j++)
			dp[i][j] = INF;
	for (int i = 1; i <= len; i++)
		dp[i][1 << i] = dis[0][i];
}
void solve()
{
	memset(dis, 0, sizeof(dis));
	int tmp, len = 0;
	d[0].x = 1, d[0].y = 1;
	for (int i = 1; i <= n; i++) {
		for (int j = 1; j <= m; j++) {
			scanf("%d", &tmp);
			if (i == 1 && j == 1) continue;
			if (tmp) d[++len].x = i, d[len].y = j;
		}
	}
	if(len == 0) {printf("0\n");return ;}
	for (int i = 0; i <= len; i++)
		for (int j = 0; j <= len; j++)
			dis[i][j] = abs(d[i].x - d[j].x) + abs(d[i].y - d[j].y);
	init(len);
	for (int s = 1; s < (1 << (len + 1)); s++) {
		for (int i = 0; i <= len; i++) {
			if (s&(1 << i)) {
				for (int j = 0; j <= len; j++)
					if (j != i && s&(1 << j))
						dp[i][s] = min(dp[i][s], dp[j][s ^ (1 << i)] + dis[j][i]);
			}
		}
	}
	printf("%d\n", dp[0][(1 << (len + 1)) - 1]);
}
int main()
{
	while (scanf("%d%d", &n, &m) != EOF)
		solve();
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值