HDU 3001 - Travelling 限制性TSP

题目链接:HDU 3001 - Travelling

题目

Problem Description

After coding so many days,Mr Acmer wants to have a good rest.So travelling is the best choice!He has decided to visit n cities(he insists on seeing all the cities!And he does not mind which city being his start station because superman can bring him to any city at first but only once.), and of course there are m roads here,following a fee as usual.But Mr Acmer gets bored so easily that he doesn’t want to visit a city more than twice!And he is so mean that he wants to minimize the total fee!He is lazy you see.So he turns to you for help.

Input

There are several test cases,the first line is two intergers n(1<=n<=10) and m,which means he needs to visit n cities and there are m roads he can choose,then m lines follow,each line will include three intergers a,b and c(1<=a,b<=n),means there is a road between a and b and the cost is of course c.Input to the End Of File.

Output

Output the minimum fee that he should pay,or -1 if he can’t find such a route.

Sample Input

2 1
1 2 100
3 2
1 2 40
2 3 50
3 3
1 2 3
1 3 4
2 3 10

Sample Output

100
90
7 

题解

这题本来我是想用双重状压,即用两个维度记录经过的点,分别是经过一次的和经过两次的,但是还没开始写,就发现了网上某大佬惊为天人的作法:用三进制, 0 , 1 , 2 0,1,2 0,1,2分别表示未经过,经过一次,经过两次。这样就完美解决了限制问题,而且时间空间也更节省。其他没什么好说的了,直接上代码:

/*虽然双重状压也是个方法,但是这里有个更稳为精妙的方法:
三进制,用0表示未访问,用1表示访问过一次,用2表示访问过两次,以此进行状压*/
#include <cstdio>
#include <cmath>
#include <algorithm>
#include <cstring>
using namespace std;

const int INF = 1e8 + 5;
int m, n;
const int sze = 59049;
int dp[11][sze];
int cnct[11][11];
bool mod[11][3];

void solve()
{
	int res = INF;
	int a, b, v, tmp;
	for(int i = 0; i < 10; i++)
		for(int j = 0; j < 10; j++)
			cnct[i][j] = INF;
	int pos = pow(3, n);
	for (int i = 0; i < m; i++){
		scanf("%d%d%d",&a ,&b ,&v);
		a -= 1, b -= 1;
		cnct[a][b] = cnct[b][a] =min(v, cnct[a][b]);
	}
	if(n == 1) {printf("0\n");return ;}
	for(int i = 0; i < n; i++){
		bool flag = false;
		for(int j = 0; j < n; j++)
			if(cnct[i][j] < INF) flag = true;
		if(!flag) {printf("-1\n"); return ;}
	}
	for(int i = 0; i < n; i++)
		for(int j = 0; j < pos; j++)
			dp[i][j] = INF;
	for(int i = 0; i < n; i++)
		dp[i][(int)pow(3,i)] = 0;
	for(int s = 1; s < pos; s++){
		bool flag = true;
		tmp = s;
		memset(mod, false, sizeof(mod));
		for(int i = 0; i < n; i++)
			mod[i][tmp % 3] = true, tmp /= 3;
		for(int i = 0; i < n; i++)
			if(mod[i][1] ||  mod[i][2])
				for(int j = 0; j < n; j++)
					if(mod[j][1] || mod[j][2])
						if(cnct[i][j] != -1)
							dp[i][s] = min(dp[i][s], dp[j][s - (int)pow(3,i)] + cnct[i][j]);
		for(int i = 0; i < n ; i++)
			if(mod[i][0]) flag = false;
		if(flag){
			for (int i = 0; i < n; i++)
				res = min(res, dp[i][s]);		
		}
	}
	if(res >= INF) printf("-1\n"); 
	else printf("%d\n",res);
}

int main()
{
	while(scanf("%d%d",&n ,&m) != EOF)
		solve();
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值