1025 PAT Ranking (25 分) 【PAT (Advanced Level) Practice】

1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number  final_rank  location_number  local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

代码: 

#include<stdio.h>
#include<string.h>
#include<algorithm>

using namespace std;
struct student
{
	char reg_num[15];
	int score;
	int fin_rank;
	int loc_num;
	int loc_rank;
} stu[30010];
bool cmp(student a,student b)
{
	if(a.score!=b.score)   return a.score>b.score;
	else  return strcmp(a.reg_num,b.reg_num)<0;
}

int main()
{
	int num=0,n,k;   //num为总人数 ,n为考场,k为考场内人数
	scanf("%d",&n);
	for(int i=1; i<=n; i++)
	{
		scanf("%d",&k);
		for(int j=0; j<k; j++)
		{
			scanf("%s %d",&stu[num].reg_num,&stu[num].score);
			stu[num].loc_num=i;
			num++;
		}

		sort(stu+num-k,stu+num,cmp);  //将每个考场的考生排序 ( 由于num是递增的,故每个考场的考生对应的数组下标区间为[num-k,num] )
		stu[num-k].loc_rank=1;        //改考场的第一名的loc_rank记为 1
		for(int j=num-k+1; j<num; j++) //改考场其余考生
		{
			if(stu[j].score==stu[j-1].score)  //分数与前一名相同则排名相同
			{
				stu[j].loc_rank=stu[j-1].loc_rank;
			}
			else
			{
				stu[j].loc_rank=j+1-(num-k);//分数不同,则loc_rank为当前考生的人数
			}
		}
	}


	printf("%d\n",num);
	sort(stu,stu+num,cmp);
	stu[0].fin_rank=1;
	for(int i=0; i<num; i++)
	{
		if(i>0&&stu[i].score!=stu[i-1].score)
		{
			stu[i].fin_rank=i+1;
		}else if(i>0&&stu[i].score==stu[i-1].score){
			stu[i].fin_rank=stu[i-1].fin_rank;
		}
		printf("%s %d %d %d\n",stu[i].reg_num,stu[i].fin_rank,stu[i].loc_num,stu[i].loc_rank);
	}
	return 0;
}

 ps:

一、步骤:

1、按照考场读入各学生的信息,并对当前读入考场的所有考生进行排序。之后将发考场的所有考生的排名写入他们的结构体。

2、对所有考生排序。

3、按排序一边计算总排名,一边输出所有考生信息。

二、注意:对同考场考生单独排序的方法:由于考生人数num自增,当读取完一个考场的考生信息(假设该考场有K个人),这个考场的考生对应的数组下标变为区间[num-k,num]。(同考场的排序在输入的时候进行,属于同一个循环)

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值