PAT (Advanced Level) Practice 1025

1025 PAT Ranking (25)(25 point(s))

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题意:输入id和分数,然后根据分数进行排名,如果分数一致,根据id从小到大排名。输出的后三列中,第一列为总体排名,第二列为所在哪一组,第三列为组内排名。理解题意后就好写了,重写一个排序函数,根据分数为第一关键字,id为第二关键字进行排序,在排序时顺便将组内排序也完成即可。

code

#include<cstdio>
#include<string>
#include<iostream>
#include<algorithm>
using namespace std;
struct Rank{
	string id;
	int score;
	int rank;
	int location;
	int local;
};
bool cmp(Rank A, Rank B){
	if(A.score == B.score){
		return A.id < B.id;
	}else{
		return A.score > B.score;
	}
}
int s_r[110][3];//i为组名,j=0时为分数,j=1时为当前人数,j=2时为当前排名 
int main(){
	Rank ranklist[30010];
	
	int n;
	scanf("%d", &n);
	int c = 0;
	for(int i = 0;i < n;i++){
		int k;
		scanf("%d", &k);
		for(int j = 0;j < k;j++){
			string id;
			int score;
			cin>>ranklist[c].id>>ranklist[c].score;
			ranklist[c].location = i + 1;
			c++;
		}
	}
	sort(ranklist, ranklist + c, cmp);
	int score = 101, num = 0, rank = 0;
	for(int i = 0;i < 110;i++){
		s_r[i][0] = 101;//初始化各组的最大成绩 
	}
	for(int i = 0;i < c;i++){
		if(ranklist[i].score < score){//全局统计 
			rank = rank + num + 1;
			num = 0;
			score = ranklist[i].score;
		}else if(ranklist[i].score == score){
			num++;
		}
		if(ranklist[i].score < s_r[ranklist[i].location][0]){//组内统计 
			s_r[ranklist[i].location][2] = s_r[ranklist[i].location][2] + s_r[ranklist[i].location][1] + 1;//和上面一样,不过是组内计算 
			s_r[ranklist[i].location][1] = 0;
			s_r[ranklist[i].location][0] = ranklist[i].score;
		}else if(ranklist[i].score == s_r[ranklist[i].location][0]){
			s_r[ranklist[i].location][1]++;
		}
		ranklist[i].local = s_r[ranklist[i].location][2];
		ranklist[i].rank = rank;
	}
	cout<<c<<endl;
	for(int i = 0;i < c;i++){
		cout<<ranklist[i].id<<" "<<ranklist[i].rank<<" "<<ranklist[i].location<<" "<<ranklist[i].local<<endl; 
	} 
	return 0;
} 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值