Crossing River(poj1700)

Problem describe
A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.
Input
The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won’t be more than 1000 people and nobody takes more than 100 seconds to cross.
Output
For each test case, print a line containing the total number of seconds required for all the N people to cross the river.
Sample Input
1
4
1 2 5 10
Sample Output
17
题意分析:这道题的意思就是n个人过河,只有一艘小船,问n个人最终到达对岸后用时最少是多少,船每次只能坐一个人或者两个人,每次来去或者回的时间为船上用时最多的那个人所需要的时间假设有两个人,用时分别为a,b为方便计算,我把n个人过河所需的时间按从小到大的顺序来排列,则这两个人过河用时为b(b>a排列之后的);假设有三个人
用时分别为:a,b,c,则此时的最优方案为用时为a的和用时为b的一起过河,用时为b,然后用时为a的再回来,此时用时为a,最后把用时为a的和用时为c的一起过河,此时用时为c,所以最后总的时间为a+b+c;假设有四个人,用时分别为a,b,c,d,此时最后最优的方案归结为两个情况,第一种情况让用时最少的把剩余的三个人一次带过去,此时用时为b+a+c+a+d,第二种情况是a先把b带过去,然后a回来,再让c,d把船开过去,然后b回来接a,此时用时共为b+a+d+b+b,AC代码如下:

#include<stdio.h>
#include<algorithm>
using namespace std;
int main()
{
	int a[1100];
	int T,n,i,sum,sum1,sum2,t1,t2,t3;
	scanf("%d",&T);
	while(T--)
	{
		sum=0;
		t2=t3=1;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		sort(a+1,a+n+1);
		/*for(i=1;i<=n;i++)
			printf("%d ",a[i]);*/
		while(n>3)
		{
			if(2*a[2]<a[1]+a[n-1])
    			sum+=(2*a[2]+a[1]+a[n]);
    		else
    			sum+=(2*a[1]+a[n-1]+a[n]);
			n-=2; //每次人数少两个
		}
		if(n<3)
			sum+=a[n];
		else
			sum+=a[1]+a[2]+a[3];
		printf("%d\n",sum); 
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值