PTA编程题 7-5 Body Mass Index Calculator (10 分)

7-5 Body Mass Index Calculator (10 分)

To determine whether a person is overweight or obese, you can use a measure called the body mass index (BMI). The formulas for calculating BMI are bmi_1.png or bmi_2.png Create a BMI calculator application that reads the user’s weight in pounds and height in inches (or, if you prefer, the user’s weight in kilograms and height in meters), then calculates and displays the user’s body mass index. Finally, evaluate his/her BMI. The BMI value is:

bmi value2.png

Input Specification:

The first line: input 1 for reads the user’s weight in pounds and height in inches, or input 2 for read the user’s weight in kilograms and height in meters; the second line: 2 double precision data for weight and height, separate by a space.

Output Specification:

The first line: print the value of BMI, keep 2 fractional digits. The second line: print the evaluation of the user’s BMI.

Sample Input:

2
52.5 1.66
Sample Output:

19.05
Normal

解:
#include<stdio.h>
int main()
{
int a;
double b,c,d;
scanf("%d\n%lf %lf",&a,&b,&c);
if(a==1)
d=b*703/c/c;
else
d=b/c/c;
if(d<18.5)
printf("%.02lf\nUnderweight",d);
else if(d<25&&d>=18.5)
printf("%.02lf\nNormal",d);
else if(d<30&&d>=25)
printf("%.02lf\nOverweight",d);
else if(d>=30)
printf("%.02lf\nObese",d);
else printf(“wrong”);
return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值