1135. Is It A Red-Black Tree (30)/红黑树 搜索建树

2 篇文章 0 订阅

    1135. Is It A Red-Black Tree (30)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:

(1) Every node is either red or black.
(2) The root is black.
(3) Every leaf (NULL) is black.
(4) If a node is red, then both its children are black.
(5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.

For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.

Figure 1
Figure 2
Figure 3

For each given binary search tree, you are supposed to tell if it is a legal red-black tree.

Input Specification:

Each input file contains several test cases. The first line gives a positive integer K (<=30) which is the total number of cases. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.

Output Specification:

For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.

Sample Input:
3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17
Sample Output:
Yes
No
No

搜索建树条件:红黑树特点:左节点比自己小,右节点比自己大

判断:1、红点不能相连

          2、每条路上黑点个数相同

    

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<map>
#include<vector>
#include<string>
#include<iostream>
using namespace std;

struct tree{
	tree *lchild;
	tree *rchild;
	int num;
}; 

bool f;
int pre;
void insert(tree* &t,int data)
{
	if(t==NULL){
		t=(tree*)malloc(sizeof(tree));
		t->num=data;
		t->lchild=NULL;
		t->rchild=NULL;
		//cout<<data<<endl;
		return ;
	}
	if(abs(data)<abs(t->num)){
		//cout<<"OK"<<endl;
		insert(t->lchild,data);		
	}	
	else
		insert(t->rchild,data);
}

void fun1(tree *t)//判断红点与黑点相连 
{
	if(t->lchild!=NULL){
		if(t->num<0&&t->lchild->num<0)
			f=false;
		else
			fun1(t->lchild);
	}
	if(t->rchild!=NULL){
		if(t->num<0&&t->rchild->num<0)
			f=false;
		else
			fun1(t->rchild);
	}
}
int fun2(tree *t)
{
	int l,r;
	if(t==NULL){
		return 1;
	}
	l=fun2(t->lchild);
	r=fun2(t->rchild);
	if(l!=r) {
		f=false;
		return -1;
	}
	if(t->num>0)
		l+=1;
	return l;
}

void print(tree *t){
	if(t->lchild) print(t->lchild);
	printf("%d ",t->num);
	if(t->rchild) print(t->rchild);
}

int main()
{
	int cas,n;
	scanf("%d",&cas);
	while(cas--){
		f=true;
		tree* t=NULL;
		scanf("%d",&n);
		for(int i=0;i<n;i++){
			scanf("%d",&pre);
			insert(t,pre);
		}
		//print(t);
		if(t->num<0) {
			printf("No\n");
			continue;
		}
		fun1(t);
		if(!f){
			printf("No\n");
			continue;
		}
		//printf("%d\n",flag);
		f=true;
		fun2(t);
		if(!f){
			printf("No\n");
			continue;
		}
		printf("Yes\n");
	}	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值