PAT甲级——1122 Hamiltonian Cycle (哈密顿回路)

1122 Hamiltonian Cycle (25 分)

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题目大意:无向图G有N个节点(标号从1到N)M条边,给出K个路径,判断每条路径是否为哈密顿回路。对于每条路径,首位相连,且图中所有的节点都访问了一遍,那么这条路径就是哈密顿回路。

思路:邻接矩阵存储图,用visit数组标记节点是否被访问过;遍历路径的时候判断当前节点是否已经访问过以及前后两个节点是否有边,同时标记已经访问过的节点,最后遍历visit数组判断是否每个节点都被访问过。

#include <iostream>
#include <vector>
using namespace std;
bool G[201][201] = { false };
bool isHamCycle(vector <int> &path, int N);
int main()
{
	int N, M, K, i;
	scanf("%d%d", &N, &M);
	for (i = 1; i <= M; i++) {
		int v, u;
		scanf("%d%d", &v, &u);
		G[v][u] = G[u][v] = true;
	}
	scanf("%d", &K);
	for (i = 1; i <= K; i++) {
		int n;
		scanf("%d", &n);
		vector <int> path(n);
		for (int j = 0; j < n; j++) 
			scanf("%d", &path[j]);
		isHamCycle(path, N) ? printf("YES\n") : printf("NO\n");
	}
}
bool isHamCycle(vector <int> &path, int N) {
	int n = path.size();
	vector <bool> visit(N + 1, false);
	if (path.front() != path.back() || n != N + 1)
		return false;
	int v = path[0], u;
	visit[v] = true;
	for (int i = 1; i < n; i++) {
		u = path[i];
		if (i != n - 1 && visit[u]) 
			return false;
		if (!G[v][u]) 
			return false;
		visit[u] = true;
		v = u;
	}
	for (int i = 1; i <= N; i++) 
		if (!visit[i]) 
			return false;
	return true;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值