PAT甲级——1132 Cut Integer (20 分)

1132 Cut Integer (20 分)

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

题目大意:将一个位数为K(K是偶数)的整数Z分为A和B,A是Z的前K/2位数,B是Z的后K/2位数,如果Z能被A*B整除,输出Yes,否则输出No。

需要注意除数为零的情况~~

#include<iostream>
#include<vector>
using namespace std;
bool check(int &Z);
int main(void)
{
	int N,Z;
	scanf("%d",&N);
	for(int i=0;i<N;i++){
		scanf("%d",&Z);
		if(check(Z)) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
 } 
bool check(int &Z)
{
	int A=0,B=0,K,flag,N=Z;
	vector<int> v;
	while(N){
		v.push_back(N%10);
		N=N/10;
	}
	K=v.size();
	for(int i=K-1;i>=K/2;i--)
	    A=A*10+v[i];
	for(int i=K/2-1;i>=0;i--)
	    B=B*10+v[i];
	if(A*B==0) return false;//加一个除数是否等于0的判断,否则会出现浮点错误 
	flag=Z%(A*B);
	return flag==0?true:false; 
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值