PAT甲级——1102 Invert a Binary Tree (层序遍历+中序遍历)

1102 Invert a Binary Tree (25 分)

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can't invert a binary tree on a whiteboard so fuck off.

Now it's your turn to prove that YOU CAN invert a binary tree!

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree -- and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:

For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:

8
1 -
- -
0 -
2 7
- -
- -
5 -
4 6

Sample Output:

3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题目大意:将二叉树每个节点的左右孩子交换位置,然后分别层序和中序输出。第 i 行代表了节点 i 的左右孩子的信息,先左后右,'-' 表示没有该方向的子节点。

思路:用数组tree存储树。

读取字符串然后将其转成int型变量,空节点'-' 用-1代替。

只要在读取数据的时候交换左右孩子的位置就行。

读取数据的时候用bool数组R对每个孩子节点进行标记,然后遍历数组寻找根节点(即没有被标记过的节点)

#include <iostream>
#include <vector>
#include <string>
#include <queue>
using namespace std;
struct node {
	int left, right;
};
vector <node> tree;
bool flag = false;//用于中序遍历标记第一个输出的节点
int getNum(string &s);
void levelOrder(int t);
void inOrder(int t);
int main()
{
	int N, root;
	scanf("%d", &N);
	tree.resize(N);
	vector <bool> R(N, true);
	for (int i = 0; i < N; i++) {
		string left, right;
		cin >> left >> right;
		tree[i].left = getNum(right);
		tree[i].right = getNum(left);
		if (tree[i].left != -1)
			R[tree[i].left] = false;
		if (tree[i].right != -1)
			R[tree[i].right] = false;
	}
	for (int i = 0; i < N; i++)
		if (R[i]) {
			root = i;
			break;
		}
	levelOrder(root);
	printf("\n");
	inOrder(root);
	printf("\n");
	return 0;
}
void inOrder(int t) {
	if (t != -1) {
		inOrder(tree[t].left);
		if (flag)
			printf(" ");
		if (!flag)
			flag = true;
		printf("%d", t);
		inOrder(tree[t].right);
	}
}
void levelOrder(int t) {
	queue <int> Q;
	Q.push(t);
	while (!Q.empty()) {
		t = Q.front();
		printf("%d", t);
		Q.pop();
		if (tree[t].left != -1) {
			Q.push(tree[t].left);
		}
		if (tree[t].right != -1) {
			Q.push(tree[t].right);
		}
		if (!Q.empty())
			printf(" ");
	}
}
int getNum(string& s) {
	if (s[0] == '-')
		return -1;
	int n = 0;
	for (int i = 0; i < s.length(); i++)
		n = n * 10 + s[i] - '0';
	return n;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值