PAT甲级——1093 Count PAT's (逻辑类型的题目)

1093 Count PAT's (25 分)

The string APPAPT contains two PAT's as substrings. The first one is formed by the 2nd, the 4th, and the 6th characters, and the second one is formed by the 3rd, the 4th, and the 6th characters.

Now given any string, you are supposed to tell the number of PAT's contained in the string.

Input Specification:

Each input file contains one test case. For each case, there is only one line giving a string of no more than 10​5​​ characters containing only PA, or T.

Output Specification:

For each test case, print in one line the number of PAT's contained in the string. Since the result may be a huge number, you only have to output the result moded by 1000000007.

Sample Input:

APPAPT

Sample Output:

2

题目大意:在一串字符中寻找能够拼凑出PAT的组合数量,字符配对要遵循原始字符串的先后顺序。

思路:开三个数组PPos、APos、TPos分别记录'P'、'A'、'T'三个字符所在的位置。遍历APos,对于当前位置的'A',在它之前的'P'的个数和在它之后的'T'的个数之积就是当前的'A'的组合数量,所有的'A'的组合数量之和就是答案。

#include <iostream>
#include <string>
#include <vector>
using namespace std;

vector<int> PPos, APos, TPos;
string s;

int main()
{
	int num = 0;
	cin >> s;
	for (int i = 0; i < s.length(); i++) {
		if (s[i] == 'P')
			PPos.push_back(i);
		if (s[i] == 'A')
			APos.push_back(i);
		if (s[i] == 'T')
			TPos.push_back(i);
	}
	int PSize = PPos.size(),
		ASize = APos.size(),
		TSize = TPos.size(),
		PIndex = 0,
		TIndex = 0;
	for (int i = 0; i < ASize; i++) {
		while (PIndex < PSize && PPos[PIndex] < APos[i]) {
			PIndex++;
		}
		while (TIndex < TSize && TPos[TIndex] < APos[i]) {
			TIndex++;
		}
		if (TIndex >= TSize)
			break;
		num += PIndex * (TSize - TIndex);
		num = num % 1000000007;
	}
	cout << num << endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值