PAT甲级——1092 To Buy or Not to Buy (字符串操作、映射)

1092 To Buy or Not to Buy (20 分)

Eva would like to make a string of beads with her favorite colors so she went to a small shop to buy some beads. There were many colorful strings of beads. However the owner of the shop would only sell the strings in whole pieces. Hence Eva must check whether a string in the shop contains all the beads she needs. She now comes to you for help: if the answer is Yes, please tell her the number of extra beads she has to buy; or if the answer is No, please tell her the number of beads missing from the string.

For the sake of simplicity, let's use the characters in the ranges [0-9], [a-z], and [A-Z] to represent the colors. For example, the 3rd string in Figure 1 is the one that Eva would like to make. Then the 1st string is okay since it contains all the necessary beads with 8 extra ones; yet the 2nd one is not since there is no black bead and one less red bead.

figbuy.jpg

Figure 1

Input Specification:

Each input file contains one test case. Each case gives in two lines the strings of no more than 1000 beads which belong to the shop owner and Eva, respectively.

Output Specification:

For each test case, print your answer in one line. If the answer is Yes, then also output the number of extra beads Eva has to buy; or if the answer is No, then also output the number of beads missing from the string. There must be exactly 1 space between the answer and the number.

Sample Input 1:

ppRYYGrrYBR2258
YrR8RrY

Sample Output 1:

Yes 8

Sample Input 2:

ppRYYGrrYB225
YrR8RrY

Sample Output 2:

No 2

题目大意:Eva要做一串色彩斑斓的珠子,店里是一整串一整串地卖,如果店里卖的一串珠子可以做出Eva想要的那种,就输出“Yes”以及用剩下的珠子的数量,否则输出“No”以及完成Eva的制作还需的珠子的数量。

思路:用map或者unordered_map记录店主和Eva的字符串里各个字符的数量,首先遍历Eva的字符--数量的映射E,若E中所有字符的数量都小于等于店主的S中的字符对应的数量,那就是“Yes”,然后遍历S,将多余的珠子数量累加;否则为“No”,将每个Eva所需字符数量店主相应字符对应数量的差值累加输出。

#include <iostream>
#include <string>
#include <unordered_map>
using namespace std;

int main()
{
	string Shop, Eva;
	unordered_map<char, int> S, E;
	cin >> Shop >> Eva;
	for (int i = 0; i < Shop.length(); i++)
		S[Shop[i]]++;
	for (int i = 0; i < Eva.length(); i++)
		E[Eva[i]]++;
	int n = 0, sum = 0, tmp;
	for (auto it = E.begin(); it != E.end(); it++) {
		tmp = S[it->first] - it->second;
		if (tmp < 0)
			n -= tmp;
	}
	if (n != 0) {
		printf("No %d\n", n);
	}
	else {
		for (auto it = S.begin(); it != S.end(); it++) {
			tmp = it->second - E[it->first];
			sum += tmp;
		}
		printf("Yes %d\n", sum);
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值