PAT甲级---1027 Colors in Mars (20 分)

1027 Colors in Mars (20 分)

People in Mars represent the colors in their computers in a similar way as the Earth people. That is, a color is represented by a 6-digit number, where the first 2 digits are for Red, the middle 2 digits for Green, and the last 2 digits for Blue. The only difference is that they use radix 13 (0-9 and A-C) instead of 16. Now given a color in three decimal numbers (each between 0 and 168), you are supposed to output their Mars RGB values.

Input Specification:
Each input file contains one test case which occupies a line containing the three decimal color values.

Output Specification:
For each test case you should output the Mars RGB value in the following format: first output #, then followed by a 6-digit number where all the English characters must be upper-cased. If a single color is only 1-digit long, you must print a 0 to its left.

Sample Input:
15 43 71
Sample Output:
#123456

#include<iostream>

using namespace std;

int main(){
	int a,b,c;
	int len1=0,len2=0,len3=0;
	int a1[10],b1[10],c1[10];
	while(scanf("%d%d%d",&a,&b,&c)!=EOF){
		do{
			a1[len1++]=a%13;
			a=a/13;
		}while(a!=0);
		
		do{
			b1[len2++]=b%13;
			b=b/13;
		}while(b!=0);
		
		do{
			c1[len3++]=c%13;
			c=c/13;
		}while(c!=0);
		
		printf("#");
		for(int i=len1-1;i>=0;i--){
			if(a1[i]<10){
				printf("%d",a1[i]);
			}else{
				printf("%c",a1[i]-'A'+10);
			}
			
		}
		for(int i=len1-1;i>=0;i--){
			if(b1[i]<10){
				printf("%d",b1[i]);
			}else{
				printf("%c",b1[i]-'A'+10);
			}
		}
		for(int i=len1-1;i>=0;i--){
			if(c1[i]<10){
				printf("%d",c1[i]);
			}else{
				printf("%c",c1[i]-'A'+10);
			}
		}
	}
	
	
	return 0;
}

10分–原因未知
参考答案

#include <cstdio>
using namespace std;
int main() {
    char c[14] = {"0123456789ABC"};
    printf("#");
    for(int i = 0; i < 3; i++) {
        int num;
        scanf("%d", &num);
        printf("%c%c", c[num/13], c[num%13]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Miraitowa_FTY

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值