How Many Answers Are Wrong HDU - 3038

How Many Answers Are Wrong HDU - 3038

Time:limit1000 ms
Memory:limit32768 kB
OS:Windows

              Source:2009 Multi-University Training Contest 13 - Host by HIT

  TT and FF are … friends. Uh… very very good friends -________-b

  FF is a bad boy, he is always wooing TT to play the following game with him. This is a very humdrum game. To begin with, TT should write down a sequence of integers-_-!!(bored).

  Then, FF can choose a continuous subsequence from it(for example the subsequence from the third to the fifth integer inclusively). After that, FF will ask TT what the sum of the subsequence he chose is. The next, TT will answer FF’s question. Then, FF can redo this process. In the end, FF must work out the entire sequence of integers.

  Boring ~~ Boring ~~ a very very boring game!!! TT doesn’t want to play with FF at all. To punish FF, she often tells FF the wrong answers on purpose.

  The bad boy is not a fool man. FF detects some answers are incompatible. Of course, these contradictions make it difficult to calculate the sequence.

  However, TT is a nice and lovely girl. She doesn’t have the heart to be hard on FF. To save time, she guarantees that the answers are all right if there is no logical mistakes indeed.

  What’s more, if FF finds an answer to be wrong, he will ignore it when judging next answers.

  But there will be so many questions that poor FF can’t make sure whether the current answer is right or wrong in a moment. So he decides to write a program to help him with this matter. The program will receive a series of questions from FF together with the answers FF has received from TT. The aim of this program is to find how many answers are wrong. Only by ignoring the wrong answers can FF work out the entire sequence of integers. Poor FF has no time to do this job. And now he is asking for your help~(Why asking trouble for himself~~Bad boy)

Input

  Line 1: Two integers, N and M (1 <= N <= 200000, 1 <= M <= 40000). Means TT wrote N integers and FF asked her M questions.

  Line 2…M+1: Line i+1 contains three integer: Ai, Bi and Si. Means TT answered FF that the sum from Ai to Bi is Si. It’s guaranteed that 0 < Ai <= Bi <= N.

  You can assume that any sum of subsequence is fit in 32-bit integer.

Output

  A single line with a integer denotes how many answers are wrong.

Sample Input

10 5
1 10 100
7 10 28
1 3 32
4 6 41
6 6 1

Sample Output

1

题意:

  有n个点,有m条语句,只知道从一个点加到另一个点的值是多少,那么在以上的语句正确的情况下,判断有多少条错误的语句。

思路:

  带权并查集,设一个方向为开区间,如果一个方向不为开区间,那么像[1,2],[3,4]便无法联立在一起。

#include<iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cmath>
#include <stack>
#include <queue>
#include <vector>
#include <set>
#include <map>
#include <functional>
#include <ctime>
#include <iomanip>
#include <numeric>
#include <sstream>
#include <algorithm>
#define ll long long
#define PI acos(-1)
#define mes(x,y) memset(x,y,sizeof(x))
#define FOR(i,a,b) for(long long i = a;i <= b;++i)
#define ROF(i,a,b) for(long long i = a;i >= b;--i)
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);cout.tie(0)
using namespace std;
const ll inf = 2e5 + 10;
const ll mod = 1e9;
ll n, m, i, j, k = 0, t, w, flag,x, y, z;
string s1, s2, s;

ll father[inf],sum[inf];

ll find(ll x) {

	if (x != father[x]) {
	
		ll t = father[x];
		
		father[x] = find(father[x]);
		
		sum[x] += sum[t];
		
	}
	
	return father[x];
	
}//从前往后依次更新father,sum的值
int main() {

	while (cin >> n >> m) {
	
		FOR(i, 0, n)father[i] = i, sum[i] = 0;
		
		ll re = 0;
		
		FOR(i, 1, m) {
		
			cin >> x >> y >> z; x--;//设置开区间
			
			ll xx = find(x), yy = find(y);
			
			if (xx == yy) {//判断是否已经在以可树上了
			
				if ((sum[x] - sum[y]) != z)re++;
				//在一棵树上,那么两个点的距离便可以判断
				//那么便判断两点之间的距离是否如输入一致
				
			}else {
			
				father[xx] = yy;//如果不在一课树上,联立这两个点所在的树
				
				sum[xx] = sum[y] + z - sum[x];//跟新不在为父亲节点的值
				
			}
			
		}
		
		cout << re << endl;
		
	}
	
	return 0;
	
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

GUESSERR

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值