How Many Trees?

A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices). 

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree? 

Input

The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set. 

Output

You have to print a line in the output for each entry with the answer to the previous question. 

Sample Input

1
2
3

Sample Output

1
2
5

 


 

 

推导公式:h(n)=h(n-1)*(4*n-2)/(n+1);

将数字一个一个存入数组

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int a[110][110];    //大数卡特兰数
int b[110];         //卡特兰数的长度 

void Catalan(){     //求卡特兰数
    int i,j,len,carry,tmp;
    a[1][0]=b[1]=1;
    len=1;
    for(i=2;i<=100;i++){
        for(j=0;j<len;j++)      //乘法 
            a[i][j]=a[i-1][j]*(4*i-2);
        carry=0;
        for(j=0;j<len;j++){     //处理相乘结果
            tmp=carry+a[i][j];
            a[i][j]=tmp%10;
            carry=tmp/10;
        }
        while(carry){       //进位处理 
            a[i][len++]=carry%10;    //一个一个存入数组直到carry=0
            carry/=10;
        }
   
        for(j=len-1;j>=0;j--){  //除法 
            tmp=carry*10+a[i][j];
            a[i][j]=tmp/(i+1);
            carry=tmp%(i+1);
        }   
        while(!a[i][len-1])     //高位零处理
            len--;
        b[i]=len;
    }
}

int main(){

    //freopen("input.txt","r",stdin);

    int n;
    Catalan();
    while(~scanf("%d",&n)){
        for(int i=b[n]-1;i>=0;i--)
            printf("%d",a[n][i]);
        printf("\n");
    }
    return 0;
}

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值