HDOJ 1130 How Many Trees?(卡特兰数+大数乘除法)

How Many Trees?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3380    Accepted Submission(s): 1958


Problem Description
A binary search tree is a binary tree with root k such that any node v reachable from its left has label (v) <label (k) and any node w reachable from its right has label (w) > label (k). It is a search structure which can find a node with label x in O(n log n) average time, where n is the size of the tree (number of vertices).

Given a number n, can you tell how many different binary search trees may be constructed with a set of numbers of size n such that each element of the set will be associated to the label of exactly one node in a binary search tree?
 

Input
The input will contain a number 1 <= i <= 100 per line representing the number of elements of the set.
 

Output
You have to print a line in the output for each entry with the answer to the previous question.
 

Sample Input
  
  
1 2 3
 

Sample Output
  
  
1 2 5
 

题意:给出一个n,每个节点的编号为1~n,问n个节点的二叉搜索树有多少种?

题解:和hdoj 1023一模一样啊,卡特兰数+大数。 不了解的点击: 点击打开链接 

代码如下:

//h(n)=h(n-1)*(4*n-2)/(n+1);
#include<cstdio>
#include<cstring>
using namespace std;
int a[110][110];
//a[n][0]表示n的卡特兰数的长度,存储是反向的,a[n][1]表示个位数 

void ktl()//打表 
{
	int i,j,len;
	int c,s;
	a[1][0]=1;
	a[1][1]=1;
	a[2][0]=1;
	a[2][1]=2;
	len=1;
	for(i=3;i<101;++i)
	{
		c=0;
		for(j=1;j<=len;++j)
		{
			s=a[i-1][j]*(4*i-2)+c;
			c=s/10;
			a[i][j]=s%10;
		}
		while(c)
		{
			a[i][++len]=c%10;
			c/=10;
		}
		for(j=len;j>0;--j)
		{
			s=a[i][j]+c*10;
			a[i][j]=s/(i+1);
			c=s%(i+1);
		}
		while(!a[i][len])
			len--;
		a[i][0]=len;
	}
}

int main()
{
	ktl();
	int n;
	while(scanf("%d",&n)!=EOF)
	{
		for(int i=a[n][0];i>0;--i)
			printf("%d",a[n][i]);
		printf("\n");
	}
	return 0;
} 



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值