Let the Balloon Rise

序言
此篇博客作为自己的学习笔记,同时欢迎大家交流!

Let the Balloon Rise

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.
This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink

代码解析
#include<iostream>
#include<cstring>
#include<algorithm>//前面三个头文件 每次习惯输入
 #include<map>//map容器头文件

using namespace std;

string s,ans;//s作为map的key 的输入,ans作为标记最多的key
map<string,int>ss;//声明
int main()
{
	int n;
    while(cin>>n){
	if(n==0)break;//n==0,结束
	int max=-1;//最大值肯定大于0,声明-1,可以
	ss.clear();//清空map容器
	for(int i=0;i<n;i++)
	{
		cin>>s;//输入key
		ss[s]++;//所对应value加1
		if(ss[s]>max){
	    ans=s;	
		max=ss[s];
	}//统计标记的惯用法
	}
		cout<<ans<<endl;//输出相对应的颜色
}
	return 0;
	
}
 
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值