what is your grade?

What Is Your Grade?

“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam!
Come on!
Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed
Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
Sample Input
4
5 06:30:17
4 07:31:27
4 08:12:12
4 05:23:13
1
5 06:30:17
-1
Sample Output
100
90
90
95

100

关键点:做对1~4题的人的时间从小到大排序,前半部分分别给65,75,85,95分,另外,需要记录学生的位置,方便排序后恢复成原来的序列。
Code:

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
struct node {
	int tm;
	int sum;
	int id;
	int same;//重复人数 
	int score;
};
bool cmp1(node x,node y){
	if(x.tm>y.tm) return 1;
	else if(x.tm==y.tm){
		if(x.sum<y.sum) return 1;
		return 0;
	}
	else return 0;
}
bool cmp2(node x,node y){
	if(x.id<y.id) return 1;
	else return 0;
}
int main(){
	int n;
	while(cin>>n&&n>=0){
		node a[n];
		int s1=0,s2=0,s3=0,s4=0;
		for(int i=0;i<n;i++){
			int x,y,z;//时分秒 
			scanf("%d %d:%d:%d",&a[i].tm,&x,&y,&z);
			if(a[i].tm==1) s1++;
			if(a[i].tm==2) s2++;
			if(a[i].tm==3) s3++;
			if(a[i].tm==4) s4++;
			a[i].sum=x*3600+y*60+z;
			a[i].id=i;
		}
		sort(a,a+n,cmp1);
		a[0].same=0; 
		for(int i=1;i<n;i++){
			if(a[i].tm==a[i-1].tm){
				a[i].same=a[i-1].same+1;
			}
			else a[i].same=0;
		} 
		for(int i=0;i<n;i++){
			switch(a[i].tm){
				case 1:if(a[i].same<s1/2) a[i].score=65;
					else a[i].score=60;break;
				case 2:if(a[i].same<s2/2) a[i].score=75;
					else a[i].score=70;break;
				case 3:if(a[i].same<s3/2) a[i].score=85;
					else a[i].score=80;break;
				case 4:if(a[i].same<s4/2) a[i].score=95;
					else a[i].score=90;break;
				case 5:a[i].score=100;break;
				default :a[i].score=50;
			}
		}
		sort(a,a+n,cmp2);
		for(int i=0;i<n;i++){
			cout<<a[i].score<<endl;
		}
		cout<<endl;
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
### 内容概要 《计算机试卷1》是一份综合性的计算机基础和应用测试卷,涵盖了计算机硬件、软件、操作系统、网络、多媒体技术等多个领域的知识点。试卷包括单选题和操作应用两大类,单选题部分测试学生对计算机基础知识的掌握,操作应用部分则评估学生对计算机应用软件的实际操作能力。 ### 适用人群 本试卷适用于: - 计算机专业或信息技术相关专业的学生,用于课程学习或考试复习。 - 准备计算机等级考试或职业资格认证的人士,作为实战演练材料。 - 对计算机操作有兴趣的自学者,用于提升个人计算机应用技能。 - 计算机基础教育工作者,作为教学资源或出题参考。 ### 使用场景及目标 1. **学习评估**:作为学校或教育机构对学生计算机基础知识和应用技能的评估工具。 2. **自学测试**:供个人自学者检验自己对计算机知识的掌握程度和操作熟练度。 3. **职业发展**:帮助职场人士通过实际操作练习,提升计算机应用能力,增强工作竞争力。 4. **教学资源**:教师可以用于课堂教学,作为教学内容的补充或学生的课后练习。 5. **竞赛准备**:适合准备计算机相关竞赛的学生,作为强化训练和技能检测的材料。 试卷的目标是通过系统性的题目设计,帮助学生全面复习和巩固计算机基础知识,同时通过实际操作题目,提高学生解决实际问题的能力。通过本试卷的学习与练习,学生将能够更加深入地理解计算机的工作原理,掌握常用软件的使用方法,为未来的学术或职业生涯打下坚实的基础。

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值