HDU 1084 What Is Your Grade?

What Is Your Grade?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5512    Accepted Submission(s): 1636


Problem Description
“Point, point, life of student!”
This is a ballad(歌谣)well known in colleges, and you must care about your score in this exam too. How many points can you get? Now, I told you the rules which are used in this course.
There are 5 problems in this final exam. And I will give you 100 points if you can solve all 5 problems; of course, it is fairly difficulty for many of you. If you can solve 4 problems, you can also get a high score 95 or 90 (you can get the former(前者) only when your rank is in the first half of all students who solve 4 problems). Analogically(以此类推), you can get 85、80、75、70、65、60. But you will not pass this exam if you solve nothing problem, and I will mark your score with 50.
Note, only 1 student will get the score 95 when 3 students have solved 4 problems.
I wish you all can pass the exam! 
Come on!
 

Input
Input contains multiple test cases. Each test case contains an integer N (1<=N<=100, the number of students) in a line first, and then N lines follow. Each line contains P (0<=P<=5 number of problems that have been solved) and T(consumed time). You can assume that all data are different when 0<p.
A test case starting with a negative integer terminates the input and this test case should not to be processed.
 

Output
Output the scores of N students in N lines for each case, and there is a blank line after each case.
 

Sample Input
  
  
4 5 06:30:17 4 07:31:27 4 08:12:12 4 05:23:13 1 5 06:30:17 -1
 

Sample Output
  
  
100 90 90 95 100
 

Author
lcy
 

分析:题意做对题,输出对应的分数,但是做对相同题数的前50%的同学有5分的加分,典型的结构体排序。

代码:

#include<stdio.h>
#include<string.h>

struct Node{
    int num;
    int n;
    int fen;
    int time;
}node[110];

int main()
{
    int sum[10];
    int total[10];
    int n,i,j,k;
    int h,m,s;
    while(scanf("%d",&n))
    {
        if(n<0)
            break;
        memset(sum,0,sizeof(sum));
        memset(total,0,sizeof(total));
        for(i=0;i<n;i++)
        {
            scanf("%d %d:%d:%d",&node[i].n,&h,&m,&s);
            node[i].num=i;
            node[i].time=3600*h+60*m+s;
            sum[node[i].n]++;
        }
        for(i=4;i>0;i--)
        {
            total[i]=total[i+1];
            total[i]+=sum[i+1];
        }
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                if(node[i].n<node[j].n)
                {
                    Node temp=node[i];
                    node[i]=node[j];
                    node[j]=temp;
                }
                else if(node[i].n==node[j].n)
                {
                    if(node[i].time>node[j].time)
                    {
                        Node temp=node[i];
                        node[i]=node[j];
                        node[j]=temp;
                    }
                }
            }
        }
            for(i=0;i<n;i++)
            {
                node[i].fen=node[i].n*10+50;
                if(node[i].n>=1&&node[i].n<5&&(((i+1)-total[node[i].n])<=sum[node[i].n]/2))
                    node[i].fen+=5;
            }
            for(i=0;i<n;i++)
            {
                for(j=i+1;j<n;j++)
                {
                    if(node[i].num>node[j].num)
                    {
                        Node temp=node[i];
                        node[i]=node[j];
                        node[j]=temp;
                    }
                }
            }
            for(i=0;i<n;i++)
            {
               printf("%d\n",node[i].fen);
            }
            printf("\n");
    }
        return 0;
}
        

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值