HDU 1097 A hard puzzle (快速幂运算 取模)

A hard puzzle

lcy gives a hard puzzle to feng5166,lwg,JGShining and Ignatius: gave a and b,how to know the a^b.everybody objects to this BT problem,so lcy makes the problem easier than begin.
this puzzle describes that: gave a and b,how to know the a^b’s the last digit number.But everybody is too lazy to slove this problem,so they remit to you who is wise.

Input

There are mutiple test cases. Each test cases consists of two numbers a and b(0<a,b<=2^30)

Output

For each test case, you should output the a^b’s last digit number.

Sample Input

7 66
8 800

Sample Output

9
6

题意:给两个整数a和b,计算a^b的最后一位数,0<a,b<=2^30。
这个题显然要用快速幂运算同时对10取模。快速取模其实采用的就是二分的思想,例如 7^66=7^33 * 7^33,7^33 = 7^16 * 7^16 * 7,7^16 = 7^8 * 7^8,7^8 = 7^4 * 7^4,7^4 = 7^2 * 72,72 = 7 * 7,这就是快速幂的思想。
AC代码如下

#include <stdio.h>

int qpow(int a, int b){
	if(b == 1) return a;
	int m = b >> 1;
	int ans = qpow(a, m) % 10;
	ans = (ans * ans) % 10;
	if(b & 1) ans = (ans * a) % 10;
	return ans;
}
int main(){
	int a, b;
	while(scanf("%d %d", &a, &b) != EOF){
		printf("%d\n", qpow(a, b));
	}
	return 0;
}

End

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值