Til the Cows Come Home
Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible
Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1…N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it
Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.
Input
* Line 1: Two integers: T and
* Lines 2…T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1…100.
Output
* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.
Sample Input
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100
Sample Output
90
题意:计算从1到N点的最短路。经典的dijkstra单源最短路。
代码
#include <iostream>
#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
int cnt = 0, head[4005] = {0}, d[1005];
struct Edge{
int next, u, v, w;
}e[4005];
struct node{
int pos;
int dis;
bool operator <( const node &x )const
{
return x.dis < dis;
}
};
inline void add(int u, int v, int w){
e[++cnt].u = u;
e[cnt].v = v;
e[cnt].w = w;
e[cnt].next = head[u];
head[u] = cnt;
}
void dijkstra(){
int vis[1005];
memset(d, 0x3f, sizeof(d));
memset(vis, 0, sizeof(vis));
d[1] = 0;
priority_queue<node> q;
q.push((node){1, 0});
while(!q.empty()){
node x = q.top();
int u = x.pos;
q.pop();
if(vis[u]) continue;
vis[u] = 1;
for(int i = head[u]; i; i = e[i].next){
int x = e[i].v;
if(d[x] > d[u] + e[i].w){
d[x] = d[u] + e[i].w;
q.push((node){x, d[x]});
}
}
}
}
int main(){
int n, m;
scanf("%d %d", &m, &n);
for(int i = 0, u, v, w; i < m; i++){
scanf("%d %d %d", &u, &v, &w);
add(u, v, w);
add(v, u, w);
}
dijkstra();
printf("%d", d[n]);
return 0;
}
End