专题I HDU-3714 Error Curves

该博客讲述了Josephina在机器学习中遇到的问题,即如何找到多个二次函数(错误曲线)的最大值点,以优化线性判别分析的性能。她发现每个数据集的测试误差曲线可以用抛物线表示,并寻求一种新的误差定义来处理多个二次函数。问题转化为找到新函数F(x) = max(Si(x))的最小值,其中Si(x)是二次函数。博主求助程序员使用三分法解决这个问题,输入包含多项式系数,输出最小值答案。
摘要由CSDN通过智能技术生成

Error Curves(三分求凹函数极值)

题面
Josephina is a clever girl and addicted to Machine Learning recently. She
pays much attention to a method called Linear Discriminant Analysis, which
has many interesting properties.
In order to test the algorithm’s efficiency, she collects many datasets.
What’s more, each data is divided into two parts: training data and test
data. She gets the parameters of the model on training data and test the
model on test data. To her surprise, she finds each dataset’s test error curve is just a parabolic curve. A parabolic curve corresponds to a quadratic function. In mathematics, a quadratic function is a polynomial function of the form f(x) = ax2 + bx + c. The quadratic will degrade to linear function if a = 0.

在这里插入图片描述

It’s very easy to calculate the minimal error if there is only one test error curve. However, there are several datasets, which means Josephina will obtain many parabolic curves. Josephina wants to get the tuned parameters that make the best performance on all datasets. So she should take all error curves into account, i.e., she has to deal with many quadric functions and make a new error definition to represent the total error. Now, she focuses on the following new function’s minimum which related to multiple quadric functions. The new function F(x) is defined as follows: F(x) = max(Si(x)), i = 1…n. The domain of x is [0, 1000]. Si(x) is a quadric function. Josephina wonders the minimum of F(x). Unfortunately, it’s too hard for her to solve this problem. As a super programmer, can you help her?

Input
The input contains multiple test cases. The first line is the number of cases T (T < 100). Each case begins with a number n (n ≤ 10000). Following n lines, each line contains three integers a (0 ≤ a ≤ 100), b (|b| ≤ 5000), c (|c| ≤ 5000), which mean the corresponding coefficients of a quadratic function.

Output
For each test case, output the answer in a line. Round to 4 digits after the decimal point.

Sample Input

2
1
2 0 0
2
2 0 0
2 -4 2

Sample Output

0.0000
0.5000

题目分析
三分算法讲解参考师兄博客:
孔止师兄博客
由此可看出此题典型三分法为求凹函数极值
注意求F(x)函数方法为遍历所有二次函数。

代码

#include<cstdio>
#include<algorithm>
#include<cstring>
#include<cmath> 

using namespace std;

int n;
int a[10005],b[10005],c[10005];
const double eps = 1e-10;
double F(double x)
{
	double Max;
	for(int i=0;i<n;i++)
	{
		if(i==0){
			Max=1.0*a[i]*x*x+1.0*b[i]*x+1.0*c[i];
		}else{
			Max=max(Max, (1.0*a[i]*x*x+1.0*b[i]*x+1.0*c[i]) );
		}
	}
	return Max;
} 
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%d%d%d",&a[i],&b[i],&c[i]);
		}
		double L=0.0,R=1000.0,mid=(L+R)/2,P=(mid+R)/2;
		while( fabs(L-R) >eps)
		{
			if( F(mid)<F(P) ){
				R=P;
			}else{
				L=mid;
			}
			mid=(L+R)/2;P=(mid+R)/2;
		}
	printf("%.4f\n",F(L));
	}
	
	return 0;
} 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值