HDU 2899 三分

http://acm.hdu.edu.cn/showproblem.php?pid=2899

Now, here is a fuction:
  F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x (0 <= x <=100)
Can you find the minimum value when x is between 0 and 100.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has only one real numbers Y.(0 < Y <1e10)

Output

Just the minimum value (accurate up to 4 decimal places),when x is between 0 and 100.

Sample Input

2
100
200

Sample Output

-74.4291
-178.8534

题目大意:给你y的值,让你求多项式F(x) = 6 * x^7+8*x^6+7*x^3+5*x^2-y*x的极小值。

思路:二分可以求单调函数的零点 而三分则是求凸(凹)函数的最值。类似二分的定义,有mid=(l+r)/2,mmid=(mid+r)/2;

比较F(mid)和F(mmid)的值,舍弃掉离极值点远的那一部分。(图片从学校集训的ppt上扣了一张233333)

#include<iostream>
#include<cstdio>
#define EPS 1e-6
using namespace std;

double y;
double Pow(double x,int t);
double cal(double x);
double check();

int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		printf("%.4f\n",cal(check()));
	}
	return 0;
}

double check()
{
	double l=0.0;
	double r=100.0;
	while(r-l>EPS)
	{
		double mid=(l+r)/2;
		double mmid=(mid+r)/2;
		if(cal(mid)<cal(mmid))
			r=mmid;
		else
			l=mid;
	}
	return l;
}

double cal(double x)
{
	return 6*Pow(x,7)+8*Pow(x,6)+7*x*x*x+5*x*x-x*y;
}

double Pow(double x,int t)
{
	double t1=1,t2=x;
	while(t>0)
	{
		if(t&1)
			t1*=t2;
		t2*=t2;
		t/=2;
	}
	return t1;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值