java:动态数组使用

java:动态数组使用

题目

从键盘读入n个整数,使用动态数组存储所读入的整数,并计算它们的和与平均值分别输出。要求尽可能使用函数实现程序代码。平均值为小数的只保留其整数部分。
样例输入: 
5 
3 4 0 0 2
样例输出:
9  1
样例输入: 
7
3 2 7 5 2 9 1
样例输出:
29  4

https://blog.csdn.net/fengyuzhengfan/article/details/39057943?ops_request_misc=%7B%22request%5Fid%22%3A%22158296001419724845019095%22%2C%22scm%22%3A%2220140713.130056874…%22%7D&request_id=158296001419724845019095&biz_id=0&utm_source=distribute.pc_search_result.none-task

import java.util.ArrayList;
import java.util.Scanner;

public class 动态数组的使用 {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner sc=new Scanner(System.in);
		int n=sc.nextInt();
		ArrayList<Integer> a=new ArrayList<Integer>();
		int sum=0,ave=0;
		for(int i=0;i<n;i++){
			int x=sc.nextInt();
			a.add(x);
			sum+=x;
		}
		if(n!=0)
			ave=sum/n;
		System.out.println(sum+" "+ave);
		
	}

}

https://blog.csdn.net/weixin_44570019/article/details/104533181?ops_request_misc=%7B%22request%5Fid%22%3A%22158296011919725211928292%22%2C%22scm%22%3A%2220140713.130056874…%22%7D&request_id=158296011919725211928292&biz_id=0&utm_source=distribute.pc_search_result.none-task

  • 0
    点赞
  • 9
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

向上Claire

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值