圆
题目链接
题目描述
给出 n n n 个圆,保证任意两个圆都不相交且不相切。
然后给出两个点 ( x 1 , y 1 ) , ( x 2 , y 2 ) (x_1,y_1),(x_2,y_2) (x1,y1),(x2,y2),保证均不在某个圆上。现在要从 ( x 1 , y 1 ) → ( x 2 , y 2 ) (x_1,y_1) \to (x_2,y_2) (x1,y1)→(x2,y2) 画条曲线,问这条曲线最少穿过多少次圆的边界?
输入格式
- 第一行为一个整数 n n n,表示圆的个数;
- 第二行是 n n n 个整数,表示 n n n 个圆的 x x x 坐标;
- 第三行是 n n n 个整数,表示 n n n 个圆的 y y y 坐标;
- 第四行是 n n n 个整数,表示 n n n 个圆的半径 r r r;
- 第五行是四个整数 x 1 , y 1 , x 2 , y 2 x_1,y_1,x_2,y_2 x1,y1,x2,y2。
输出格式
仅一个整数,表示最少要穿过多少次圆的边界。
样例 #1
样例输入 #1
7
1 -3 2 5 -4 12 12
1 -1 2 5 5 1 1
8 1 2 1 1 1 2
-5 1 12 1
样例输出 #1
3
提示
【数据范围】
对于 100 % 100\% 100% 的数据, 1 ≤ n ≤ 50 1\le n \le 50 1≤n≤50, ∣ x ∣ , ∣ y ∣ ≤ 1000 |x|,|y| \le 1000 ∣x∣,∣y∣≤1000, 1 ≤ r ≤ 1000 1 \le r \le 1000 1≤r≤1000。
保证圆之间没有公共点。
题解思路
这是计算几何的一道入门题,难点在于将这个问题转化。
题中所述,给出了几个圆,和两个点,要求的是这两个点之间所形成的曲线与圆交点数量的最小值。
在只有一个圆,两个点的情况下:
- 如果两个点在同一个圆内或者同时在圆外,那么他们所连曲线与圆最少有0个交点。
- 如果一个点在一个圆内,另外一个点在圆外,那么他们所连曲线与圆最少有1个交点。
将情况拓展到多个圆,题目问题就简单了,就是看这两个点在几个不同的圆内。而判断两个点是否在圆内就是比较点到圆心的距离是否小于圆的半径。
题解代码
此处为了方便理解,将圆的数据抽象成了一个类
#include <bits/stdc++.h>
using namespace std;
class Circle
{
public:
int x, y, r;
};
class Point
{
public:
int x, y;
};
double distance(int x1, int y1, int x2, int y2)
{
return sqrt((x1 - x2) * (x1 - x2) + (y1 - y2) * (y1 - y2));
}
int main()
{
int n;
scanf("%d", &n);
Circle circles[n];
for (register int i(0); i < n; ++i)
{
scanf("%d", &circles[i].x);
}
for (register int i(0); i < n; ++i)
{
scanf("%d", &circles[i].y);
}
for (register int i(0); i < n; ++i)
{
scanf("%d", &circles[i].r);
}
Point p1;
Point p2;
scanf("%d %d %d %d", &p1.x, &p1.y, &p2.x, &p2.y);
int res = 0;
for (register int i(0); i < n; ++i)
{
// 两个点一个在圆内一个在圆外,异或
if((distance(circles[i].x,circles[i].y,p1.x,p1.y) < circles[i].r) ^
(distance(circles[i].x,circles[i].y,p2.x,p2.y) < circles[i].r))
{
++res;
}
}
printf("%d", res);
return 0;
}