PAT甲级 1036 Boys vs Girls(25分)

题目

This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference gradeF−gradeM. If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

Sample Input1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output1:

Mary EE990830
Joe Math990112
6

Sample Input2:

1
Jean M AA980920 60

Sample Output2:

Absent
Jean AA980920
NA

题解

题目大意

给出n行数据,每行数据内容为男孩或女孩信息(姓名、性别、ID、名次),找到名次最高的女孩和名次最低的男孩,并计算两者名次差。

非正规思路

首先看完题目,可以分析得出这是一道模拟题(也就是不涉及什么复杂的算法啥的,按部就班地用代码把题目过程表示出来就可以)。以下为非正规的三步走过程:
输入
① 整数N(表示接下来人员数)
② 姓名 性别 ID 名次
过程
每输入一行记录,如果是男孩,则对低名次记录进行更新,如果是女孩,则对高名次记录进行更新。对于Absent的输出结果则是对minn和maxn分别进行判断。
输出
① 女孩姓名 女孩编号(若无,则输出Absent)
② 男孩姓名 男孩编号(若无,则输出Absent)
③ 名次差(若无,则输出NA)

挫挫的代码

#include<bits/stdc++.h>
using namespace std;
int main(){
	int n;
	while(scanf("%d",&n)!=EOF){
		int minn = INT_MAX, maxn = INT_MIN;
		string male, female, maleCode, femaleCode;
		int gradeMF;
		for(int i=0;i<n;i++){
			string name, gender, id;
			int grade;
			cin >> name >> gender >> id;
			scanf("%d",&grade);
			if(gender == "M"){
				if(grade < minn){
					minn = grade;
					male = name;
					maleCode = id;
				}
			}
			if(gender == "F"){
				if(grade > maxn){
					maxn = grade;
					female = name;
					femaleCode = id;
				}
			}
		}
		gradeMF = abs(maxn - minn);
		if(maxn == INT_MIN){
			cout<<"Absent"<<endl;
		}else{
			cout<<female<<" "<<femaleCode<<endl;
		}
		if(minn == INT_MAX){
			cout<<"Absent"<<endl;
		}else{
			cout<<male<<" "<<maleCode<<endl;
		}
		if(minn == INT_MAX || maxn == INT_MIN){
			cout<<"NA"<<endl;
		}else{
			cout<<gradeMF<<endl;
		}
	} 
	return 0;
}

絮絮叨叨

刷题代替午觉的快乐……

参考博客

https://blog.csdn.net/a617976080/article/details/89676670

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值