PAT甲级 1011 World Cup Betting (20 分)

题目

With the 2010 FIFA World Cup running, football fans the world over were becoming increasingly excited as the best players from the best teams doing battles for the World Cup trophy in South Africa. Similarly, football betting fans were putting their money where their mouths were, by laying all manner of World Cup bets.

Chinese Football Lottery provided a “Triple Winning” game. The rule of winning was simple: first select any three of the games. Then for each selected game, bet on one of the three possible results – namely W for win, T for tie, and L for lose. There was an odd assigned to each result. The winner’s odd would be the product of the three odds times 65%.

For example, 3 games’ odds are given as the following:

W T L
1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

To obtain the maximum profit, one must buy W for the 3rd game, T for the 2nd game, and T for the 1st game. If each bet takes 2 yuans, then the maximum profit would be (4.1×3.1×2.5×65%−1)×2=39.31 yuans (accurate up to 2 decimal places).

Input Specification:

Each input file contains one test case. Each case contains the betting information of 3 games. Each game occupies a line with three distinct odds corresponding to W, T and L.

Output Specification:

For each test case, print in one line the best bet of each game, and the maximum profit accurate up to 2 decimal places. The characters and the number must be separated by one space…

Sample Input:

1.1 2.5 1.7
1.2 3.1 1.6
4.1 1.2 1.1

Sample Output:

T T W 39.31

题解

题目大意

给出n行数据,每行数据内容为男孩或女孩信息(姓名、性别、ID、名次),找到名次最高的女孩和名次最低的男孩,并计算两者名次差。

非正规思路

首先看完题目,可以分析得出这是一道模拟题(也就是不涉及什么复杂的算法啥的,按部就班地用代码把题目过程表示出来就可以)。以下为非正规的三步走过程:
输入
① 3场比赛,一行一场投注信息
② 每一行对应每场比赛W T L对应的odds corresponding
过程
计算最大利润,本质是找出每场比赛odds corresponding最大的数值,代入公式计算即可。
输出
① 每场比赛的最佳投注和最大利润值

挫挫的代码

#include<bits/stdc++.h>
using namespace std;
int main(){
	double games[3][3];
	char resP[3] = {'W','T','L'};
	char res[3];
	double ans = 1; 
	for(int i=0;i<3;i++){
		double maxn = 0;
		for(int j=0;j<3;j++){
			scanf("%lf",&games[i][j]);
			if(games[i][j]>maxn){
				maxn = games[i][j];
				res[i] = resP[j];
			}
		} 
		ans *= maxn;
	}
	ans = (ans * 0.65 -1) * 2;
	for(int i=0;i<3;i++){
		cout<<res[i]<<" ";
	}
	printf("%.2f",ans);
	return 0;
} 

絮絮叨叨

吃完晚饭困了,来刷一题……

参考博客

https://blog.csdn.net/a617976080/article/details/89676670

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值