整除的尾数
Time Limit: 1000/1000 MS (Java/Others) | Memory Limit: 32768/32768 K (Java/Others) |
---|
Problem Description
一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢?
Input
输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束。
Output
对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
Sample Input
200 40
1992 95
0 0
Sample Output
00 40 80
15
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <complex>
using namespace std;
int main()
{
int a, b;
int ans[105];
while(scanf("%d%d", &a, &b), a||b)
{
int t=0;
for(int i=0; i<=99; i++)
if((a*100+i)%b==0)
ans[t++]=i;
for(int i=0; i<t; i++)
printf("%02d%c", ans[i], i==t-1 ? '\n':' ');
}
return 0;
}