POJ -2406 Power Strings(KMP,循环节)

Power Strings

Time Limit: 3000MSMemory Limit: 65536K

Description
Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output
For each s you should print the largest n such that s = a^n for some string a.

Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <complex>
using namespace std;
const int N=1e6;

char s[N+5], p[N+5];
int nxt[N+5];
int plen, slen;

void getNext()//求失配数组模板
{
    int i=0,j=-1;
    nxt[0]=-1;
    while(i<slen)
    {
        if(j==-1||s[i]==s[j])
            nxt[++i]=++j;
        else
            j=nxt[j];
    }
}

int main()
{
    while(scanf("%s", s), s[0]!='.')//这个'.'啊!!都没看见
    {
        slen=strlen(s);
        getNext();
        int cycle_len=slen-nxt[slen];
        if(slen%cycle_len==0)//=0表示内部存在循环,否则自身就是一个循环
            printf("%d\n", slen/cycle_len);
        else
            printf("1\n");
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值