Power Strings
Time Limit: 3000MS | Memory Limit: 65536K |
---|
Description
Given two strings a and b we define ab to be their concatenation. For example, if a = “abc” and b = “def” then ab = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).
Input
Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output
For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.
Sample Output
1
4
3
#include <iostream>
#include <algorithm>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdio>
#include <queue>
#include <set>
#include <map>
#include <vector>
#include <complex>
using namespace std;
const int N=1e6;
char s[N+5], p[N+5];
int nxt[N+5];
int plen, slen;
void getNext()//求失配数组模板
{
int i=0,j=-1;
nxt[0]=-1;
while(i<slen)
{
if(j==-1||s[i]==s[j])
nxt[++i]=++j;
else
j=nxt[j];
}
}
int main()
{
while(scanf("%s", s), s[0]!='.')//这个'.'啊!!都没看见
{
slen=strlen(s);
getNext();
int cycle_len=slen-nxt[slen];
if(slen%cycle_len==0)//=0表示内部存在循环,否则自身就是一个循环
printf("%d\n", slen/cycle_len);
else
printf("1\n");
}
return 0;
}