HDU -1023 Train Problem II(卡特兰数、大数乘法)

Train Problem II

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)

Problem Description
As we all know the Train Problem I, the boss of the Ignatius Train Station want to know if all the trains come in strict-increasing order, how many orders that all the trains can get out of the railway.

Input
The input contains several test cases. Each test cases consists of a number N(1<=N<=100). The input is terminated by the end of file.

Output
For each test case, you should output how many ways that all the trains can get out of the railway.

Sample Input
1
2
3
10

Sample Output
1
2
5
16796

Hint
The result will be very large, so you may not process it by 32-bit integers.

h( n ) = ( ( 4*n-2 )/( n+1 )*h( n-1 ) )
打表卡特兰数
第 n个 卡特兰数存在a[n]中,a[n][0]表示长度;
注意数是倒着存的,个位是 a[n][1] 输出时注意倒过来。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<algorithm>
#include<stack>
#include<vector>
using namespace std;

#define maxn 120
int a[maxn][maxn];
void Catalan()
{
    //計算公式:h(n)=h(n-1)*(4*n-2)/(n+1);
    int len, carry, temp;
    a[2][0]=1;
    a[2][1]=2;
    a[1][0]=1;
    a[1][1]=1;
    len = 1;
    for(int i = 3; i <= 100; i++)
    {
        for(int j = 1; j <= len; j++)
        {
            a[i][j] = a[i - 1][j] * (4 * (i - 1) + 2);
        }
        carry = 0;//进位or退位
        for(int j = 1; j <= len; j++)
        {
            temp = a[i][j] + carry;
            a[i][j] = temp % 10;
            carry = temp / 10;
        }
        while(carry)//把没进的位进上去
        {
            a[i][++len] = carry % 10;
            carry /= 10;
        }
        for(int j = len; j >= 1; j--)
        {
            temp = carry * 10 + a[i][j];
            a[i][j] = temp / (i + 1);
            carry = temp % (i + 1);
        }
        while(!a[i][len])
            len--;
        a[i][0]=len;
    }
}

int main()
{
    int n;
    Catalan();
    while(~scanf("%d", &n))
    {
        for(int k = a[n][0]; k >= 1; k--)
            printf("%d",a[n][k]);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值