ACboy needs your help again!
Time Limit: 1000/1000 MS (Java/Others) | Memory Limit: 32768/32768 K (Java/Others) |
---|
Problem Description
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor ?.
As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
Output
For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.
Sample Input
4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT
Sample Output
1
2
2
1
1
2
None
2
3
题意:样例数t,每个样例第一行是命令数n以及出栈规则,下面n行是命令,"IN d"表示d入栈,“OUT"表示出栈并且输出出栈元素,若没有输出"None”
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<cmath>
#include<queue>
#include<algorithm>
#include<stack>
#include<vector>
using namespace std;
struct node
{
int id, m;//id是编号,方便排序
node(int id, int m):id(id),m(m) {};
};
struct cmp_fifo//id小的排在栈顶
{
bool operator()(node a, node b)
{
return a.id>b.id;
}
};
struct cmp_filo//id大的排在栈底
{
bool operator()(node a, node b)
{
return a.id<b.id;
}
};
int main()
{
int t;
scanf("%d", &t);
while(t--)
{
int n;
char com[10];
scanf("%d%s", &n, com);
int id=0;
if(!strcmp(com,"FIFO"))
{
priority_queue<node, vector<node>, cmp_fifo> s;
int m;
char cnd[10];
while(n--)
{
scanf("%s", cnd);
if(!strcmp(cnd, "IN"))
{
scanf("%d", &m);
s.push(node(id++, m));
}
else
{
if(s.empty())
printf("None\n");
else
{
printf("%d\n", s.top().m);
s.pop();
}
}
}
}
else
{
priority_queue<node, vector<node>, cmp_filo> s;
int m;
char cnd[10];
while(n--)
{
scanf("%s", cnd);
if(!strcmp(cnd, "IN"))
{
scanf("%d", &m);
s.push(node(id++, m));
}
else
{
if(s.empty())
printf("None\n");
else
{
printf("%d\n", s.top().m);
s.pop();
}
}
}
}
}
return 0;
}