HDU -1069 Monkey and Banana(dp)

M - Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 65536/32768 K (Java/Others)

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.
The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.
They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.
Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

先对x,y,z进行由小到大排序得到 a[0],a[1],a[2],可以得到(x[0], x[1], x[2]),(x[1], x[2], x[0]),(x[0], x[2], x[1])三种排序方式,为了方便比较,长和宽小的在前(6,8,10和10,8,6这种情况,采用 x1<x2&&y1<y2 的比较方法就不可行)。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;
#define INF 0x3f3f3f3f

struct node
{
    int x, y, z;
    node(int x,int y,int z):x(x),y(y),z(z){}
}p[100]=node(-1,-1,-1);

int cmp(node a, node b)//先排序x,再排序y
{
    if(a.x==b.x)
        return a.y>b.y;
    return a.x>b.x;
}

int dp[105];

int main()
{
    int n, cas=0;
    while(scanf("%d",&n),n)
    {
        int t=1, x[3];
        while(n--)
        {
            scanf("%d%d%d", &x[0], &x[1], &x[2]);
            sort(x,x+3);
            p[t++]=node(x[0], x[1], x[2]);
            p[t++]=node(x[1], x[2], x[0]);
            p[t++]=node(x[0], x[2], x[1]);
        }
        sort(p+1, p+t+1, cmp);
        memset(dp, 0, sizeof(dp));
        p[0].x=p[0].y=INF;
        int ans=0;
        for(int i=1; i<t; i++)//i表示当前的一个矩形
        {
            for(int j=0; j<i; j++)//j表示i下面的矩形,dp找第i个矩形的最优解
            {
                if(p[j].x>p[i].x&&p[j].y>p[i].y)//只要j的长宽都大于i的长宽
                    dp[i]=max(dp[i], dp[j]+p[i].z);//那么dp[i]的当前最优解就是max(dp[i], dp[j]+p[i].z)
            }
            ans=max(ans, dp[i]);
        }
        printf("Case %d: maximum height = %d\n", ++cas, ans);
    }
    return 0;
}

看这个人来的灵感:https://blog.csdn.net/a915800048/article/details/50822224

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值