1069 The Black Hole of Numbers (超时终于找到原因啦)

1069 The Black Hole of Numbers (20 point(s))

For any 4-digit integer except the ones with all the digits being the same, if we sort the digits in non-increasing order first, and then in non-decreasing order, a new number can be obtained by taking the second number from the first one. Repeat in this manner we will soon end up at the number 6174 -- the black hole of 4-digit numbers. This number is named Kaprekar Constant.

For example, start from 6767, we'll get:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174
7641 - 1467 = 6174
... ...

Given any 4-digit number, you are supposed to illustrate the way it gets into the black hole.

Input Specification:

Each input file contains one test case which gives a positive integer N in the range (0,10​4​​).

Output Specification:

If all the 4 digits of N are the same, print in one line the equation N - N = 0000. Else print each step of calculation in a line until 6174 comes out as the difference. All the numbers must be printed as 4-digit numbers.

Sample Input 1:

6767

Sample Output 1:

7766 - 6677 = 1089
9810 - 0189 = 9621
9621 - 1269 = 8352
8532 - 2358 = 6174

Sample Input 2:

2222

Sample Output 2:

2222 - 2222 = 0000

这题总的来说还是很简单的啦,关键就是4位数在int 和char 数组之间的 变换吧。

开始时候一直是14分,有几个测试点显示是超时,后来中遇发现啦,因为在输入的地方,我开始是用的字符数组来接收的,然而输入的是个数字啊,可能是10啊,0啊,不一定是四位数,这个就是审题的问题了,好啦,代码如下啦:

#include <cstdio>
#include <algorithm>

using namespace std;
bool compare(char a,char b)  //升序
{
	return a<b;
}
bool compare1(char a,char b) //降序
{
	return a>b;
}

int StrToInt(char str[])
{
	int num=0;
	for(int i=0;i<4;i++)
		num=num*10+str[i]-'0';
//	num=1000*(str[0]-'0')+100*(str[1]-'0')+10*(str[2]-'0')+(str[3]-'0');
	return num;
}
void IntToStr(char str[],int num)
{
	int a=1000;
	for(int i=0;i<4;i++)
	{
		str[i]=num/a+'0';
		num=num%a;
		a=a/10;
	}
}
int  Print(char str[])
{
	int i,num,max,min;
	sort(str,str+4,compare1);
	max=StrToInt(str);
//	for(i=0;i<4;i++)
//	{
//		pritnf("%d",str[i]='0');
//	}
	printf("%04d - ",max);
	sort(str,str+4,compare);
	min=StrToInt(str);
	num=max-min;
	printf("%04d = %04d\n",min,num);
	return num;
}
int main()
{
	int i,num,last=0;
	char str[5];
	
	scanf("%d",&num);
/*     原本是如下代码,超时
        for(i=0;i<4;i++)
	{
		scanf("%c",&str[i]);
	}
	num=StrToInt(str);
	num=Print(str);
*/
	
	IntToStr(str,num);
	num=Print(str);

	while(num!=0 && num!=6174)
	{
		IntToStr(str,num);
		num=Print(str);
	}

}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值