POJ -3414 Pots(BFS)

Pots

Time Limit: 1000MSMemory Limit: 65536K

Description
You are given two pots, having the volume of A and B liters respectively. The following operations can be performed:

FILL(i) fill the pot i (1 ≤ i ≤ 2) from the tap;
DROP(i) empty the pot i to the drain;
POUR(i,j) pour from pot i to pot j; after this operation either the pot j is full (and there may be some water left in the pot i), or the pot i is empty (and all its contents have been moved to the pot j).
Write a program to find the shortest possible sequence of these operations that will yield exactly C liters of water in one of the pots.

Input
On the first and only line are the numbers A, B, and C. These are all integers in the range from 1 to 100 and C≤max(A,B).

Output
The first line of the output must contain the length of the sequence of operations K. The following K lines must each describe one operation. If there are several sequences of minimal length, output any one of them. If the desired result can’t be achieved, the first and only line of the file must contain the word ‘impossible’.

Sample Input
3 5 4

Sample Output
6
FILL(2)
POUR(2,1)
DROP(1)
POUR(2,1)
FILL(2)
POUR(2,1)

之前模拟"上下左右"4个ca,这次模拟"FILL(i),FILL(j),POUR(i,j),POUR(j,i),DROP(i),DROP(j)"6个操作。

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;

struct node
{
    int aa, bb;//两个杯子此时的装水体积
    int level;//操作次数
    string ope;//存操作顺序
} p, pp;

queue<node>s;
int vis[105][205];//访问标记
int a, b, c;

int bfs()
{
    while(!s.empty())
        s.pop();
    p.aa=0, p.bb=0;
    p.level=0, p.ope="";
    s.push(p);
    vis[0][0]=1;
    while(!s.empty())
    {
        p=s.front();
        s.pop();
        if(p.aa==c||p.bb==c)
            return 1;
        int aa, bb;
        for(int i=1; i<=6; i++)
        {
            if(i==1)//加满a
                aa=a, bb=p.bb;
            else if(i==2)//加满b
                aa=p.aa, bb=b;
            else if(i==3)//b倒水给a
            {
                if(p.aa+p.bb>a)
                    bb=p.bb+p.aa-a, aa=a;
                else
                    bb=0, aa=p.aa+p.bb;
            }
            else if(i==4)//a倒水给b
            {
                if(p.aa+p.bb>b)
                    aa=p.aa+p.bb-b, bb=b;
                else
                    aa=0, bb=p.aa+p.bb;
            }
            else if(i==5)//倒光a
                aa=0, bb=p.bb;
            else//倒光b
                bb=0, aa=p.aa;
            if(vis[aa][bb]==0)
            {
                vis[aa][bb]=1;
                pp.aa=aa, pp.bb=bb;
                pp.level=p.level+1;
                pp.ope="";//用string特别方便
                pp.ope+=(p.ope+char(i+'0'));
                s.push(pp);
            }
        }
    }
    return 0;
}

void output()
{
    printf("%d\n", p.level);
    for(int i=0; i<p.level; i++)
    {
        if(p.ope[i]=='1')
            printf("FILL(1)\n");
        else if(p.ope[i]=='2')
            printf("FILL(2)\n");
        else if(p.ope[i]=='3')
            printf("POUR(2,1)\n");
        else if(p.ope[i]=='4')
            printf("POUR(1,2)\n");
        else if(p.ope[i]=='5')
            printf("DROP(1)\n");
        else
            printf("DROP(2)\n");
    }
}

int main()
{
    while(scanf("%d%d%d", &a, &b, &c)!=EOF)
    {
        memset(vis, 0, sizeof(vis));
        if(bfs())
            output();
        else
            printf("impossible\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值