POJ -2251 Dungeon Master(三维地图BFS)

Dungeon Master

Time Limit: 1000MSMemory Limit: 65536K

Description
You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a ‘#’ and empty cells are represented by a ‘.’. Your starting position is indicated by ‘S’ and the exit by the letter ‘E’. There’s a single blank line after each level. Input is terminated by three zeroes for L, R and C.

Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line
Trapped!

Sample Input
3 4 5
S…
.###.
.##…
###.#

##.##
##…

#.###
####E

1 3 3
S##
#E#

0 0 0

Sample Output
Escaped in 11 minute(s).
Trapped!

一看这tm还分层,吓了一跳,不过想了想就是在横纵坐标上加了一个层坐标而已

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#include<queue>
using namespace std;

int l, r, c, ans;
int sl, sr, sc, el, er, ec;//s是起点,e是终点
char map[31][31][31];//map[i][j][k]表示第i层第j行第k列
int vis[31][31][31];//标记数组
int dir[6][3]={{0,1,0},{0,-1,0},{0,0,1},{0,0,-1},{1,0,0},{-1,0,0}};//同一层上下左右和上一层下一层

struct point
{
    int l, r, c;
    int step;
    point(int l,int r,int c,int step):l(l),r(r),c(c),step(step){}
};

int check(int x, int y, int z)
{
    if(x<0||y<0||z<0||x>=l||y>=r||z>=c)//越界
        return 1;
    else if(map[x][y][z]=='#')//撞墙
        return 1;
    else if(vis[x][y][z])//此状态已经被访问
        return 1;
    return 0;
}

int bfs()
{
    queue<point>p;
    p.push(point(sl, sr, sc, 0));
    vis[sl][sr][sc]=1;
    while(!p.empty())
    {
        point now=p.front();
        p.pop();
        if(now.l==el&&now.r==er&&now.c==ec)//到达终点
        {
            ans=now.step;
            return 1;
        }
        int ll, rr, cc, st;
        for(int i=0; i<6; i++)
        {
            ll=now.l+dir[i][0];
            rr=now.r+dir[i][1];
            cc=now.c+dir[i][2];
            st=now.step+1;
            if(check(ll, rr, cc))
                continue;
            vis[ll][rr][cc]=1;
            p.push(point(ll,rr,cc,st));
        }
    }
    return 0;
}

int main()
{
    while(scanf("%d%d%d", &l, &r, &c), l||r||c)
    {
        for(int i=0; i<l; i++)
        {
            for(int j=0; j<r; j++)
            {
                scanf("%s", map[i][j]);
                if(strchr(map[i][j], 'S'))
                    sl=i, sr=j, sc=strchr(map[i][j], 'S')-map[i][j];
                if(strchr(map[i][j], 'E'))
                    el=i, er=j, ec=strchr(map[i][j], 'E')-map[i][j];
            }
        }
        memset(vis, 0, sizeof(vis));
        if(bfs())
            printf("Escaped in %d minute(s).\n", ans);
        else
            printf("Trapped!\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值