hdu-1702ACboy needs your help again!(栈和队列)

题意描述:
题目最开始的时候给你一个字串FIFO先进先出然后是IN表示输入一个数,OUT表示在这个时候你需要输出一个数按照先进先出的规则对于刚存入的数进行输出,再有就是FILO先进后出这个判断比先进先出要简单一些,他只需要定义一个变量即可从最后输入的是开始往后依次输出就行。
需要注意的地方就是在输出的时候对于第一类情况就判断输出的数的个数是否大于或等于输入的数的个数,要是大于或等于的话就直接输出None(因为在输出入的时候在最后一个数自加1输出的时候自减1所以等于的时候也算是没有数据的情况),对于第二类输出的情况就简单的判断一下存入的数是否没有了的情况就可以另外在输出的时候记得输出–num(输入的时候多自加1)
下面是原文题目:
ACboy was kidnapped!!
he miss his mother very much and is very scare now.You can’t image how dark the room he was put into is, so poor ?.
As a smart ACMer, you want to get ACboy out of the monster’s labyrinth.But when you arrive at the gate of the maze, the monste say :" I have heard that you are very clever, but if can’t solve my problems, you will die with ACboy."
The problems of the monster is shown on the wall:
Each problem’s first line is a integer N(the number of commands), and a word “FIFO” or “FILO”.(you are very happy because you know “FIFO” stands for “First In First Out”, and “FILO” means “First In Last Out”).
and the following N lines, each line is “IN M” or “OUT”, (M represent a integer).
and the answer of a problem is a passowrd of a door, so if you want to rescue ACboy, answer the problem carefully!
Input
The input contains multiple test cases.
The first line has one integer,represent the number oftest cases.
And the input of each subproblem are described above.
Output
For each command “OUT”, you should output a integer depend on the word is “FIFO” or “FILO”, or a word “None” if you don’t have any integer.
Sample Input

4
4 FIFO
IN 1
IN 2
OUT
OUT
4 FILO
IN 1
IN 2
OUT
OUT
5 FIFO
IN 1
IN 2
OUT
OUT
OUT
5 FILO
IN 1
IN 2
OUT
IN 3
OUT

Sample Output

1
2
2
1
1
2
None
2
3

AC代码:

#include<stdio.h>
#include<string.h>
int main()
{
	int i,j,k,n,m,num,p,q,t;
	int a[1200];
	char str1[20],str2[20];
	scanf("%d", &n);
	while(n--)
	{
	memset(a,0,sizeof(a));
	 scanf("%d %s", &m,str1);
	 if(strcmp(str1,"FIFO")==0)
	 {
	     p=0,q=0;
	 	while(m--)
	 	{ 
	 		scanf("%s", str2);
	 		if(strcmp(str2,"IN")==0)
	 		{
	 			scanf("%d",&num);
	 			a[p++]=num;
			 }
			 else  if(strcmp(str2,"OUT")==0)
			 {
			 	if(q>=p)
			 	printf("None\n");
			 	else
			 	printf("%d\n", a[q++]);
			 }
		 }
	 }
	 else if(strcmp(str1,"FILO")==0)
	 { 
	    t=0;
	 	while(m--)
	 	{
		    scanf("%s", str2);
	 		if(strcmp(str2,"IN")==0)
	 		{
	 			scanf("%d", &num);
	 			a[t++]=num;
			 }
			 else if(strcmp(str2,"OUT")==0)
			 {
			 	if(t==0)
			 	printf("None\n");
			 	else
			 	printf("%d\n", a[--t]);
			 }
		 }
	  }
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值