poj--1979Red and Black(深搜)

题目:
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ - a black tile
‘#’ - a red tile
‘@’ - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

题意描述:
符号 ‘.’ - 黑色瓷砖 ‘#’ - 红色瓷砖 ‘@’ - 黑色瓷砖上的男人,看看他可以移动的位置有多少;
解题思路:
将走过的.变成#按照右下左上的顺序遍历,当没有路可以走的时候输出他可以走的步数
AC代码:

#include<stdio.h>
#include<string.h>
char a[31][31];
int n,m,min;
void dfs(int x, int y)
{
    min++;
    a[x][y]='#';
    int tx,ty,k;
	int next[4][2]={  {-1,0},
					  {1, 0},
					  {0, 1}, 
					  {0, -1}};
    for(k=0; k<=3; k++)
    {
        tx=x+next[k][0];
    	ty=y+next[k][1];
        if (tx>0&&ty>0&&tx<=n&&ty<=m&&a[tx][ty]=='.')
            dfs(tx,ty);
    }
    return;
}
int main()
{
    int i,j,c,d;
    while(scanf("%d%d", &m, &n),n!=0&&m!=0)
	{
    	min=0;
       for (i=1; i<=n; i++)
	   {
       	    getchar();
           for (j=1; j<=m; j++)
		   {
               scanf("%c", &a[i][j]);
               if (a[i][j] == '@')
                   c=i;d=j;
           }
       }
       dfs(c,d);
       printf("%d\n", min);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值