poj-1066Candy Sharing Game分糖果

题目:
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
Input
The input may describe more than one game. For each game, the input begins with the number N of students,followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with,both on one line.
Sample Input

6
36
2
2
2
2
2
11
22
20
18
16
14
12
10
8
6
4
2
4
2
4
6
8
0

Sample Output

15 14
17 22
4 8

题意描述:
最开始每个人都有一定数目的糖果,老师吹哨时右边的把自己糖果的一半给左边,在这个过程中要是谁的糖果数是奇数会多得一个,最后每个人的糖果数目相等的情况下结束游戏;
解题思路:
就用一个循环来搞定,先把每个数除2后依次往前相加,不过在想加之前把a[2]/2记录下来在a[n]+a[1]的时候用,再检查是否有奇数然后再来一个遍历检查是否每个数相等即可;
AC代码

#include<stdio.h>
int a[200];
int main()
{
	int i,n;
	while(scanf("%d", &n),n!=0)
	{
		for(i=1; i<=n; i++)
		 scanf("%d", &a[i]);
		int t=0,s=0,p,q;
		while(t==0)
		{
			p=0;s++;
			for(i=1; i<=n; i++)
			{
			  	a[i]/=2;
			}
		    q=a[2];
			for(i=1; i<n; i++)
			{
			  	a[i]+=a[i+1];
			}
			a[n]+=a[1]-q;
			for(i=1; i<=n; i++)
			{
				 if(a[i]%2==1)
			     a[i]++;
			}
			for(i=1; i<n; i++)
			{
				if(a[i]!=a[i+1])
				{
					t=0;
					break;
				}
				else
				p++;
			}
			if(p==n-1)
			t=1;
		}
		printf("%d %d\n", s,a[1]);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

皮皮皮皮皮皮皮卡乒

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值