The Suspects POJ - 1611(并查集)

讲解并查集很好的:博客1
讲解并查集很好的:博客2
题目链接
Vjudje
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output
For each case, output the number of suspects in one line.
Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0
Sample Output
4
1
1

题意:
有很多组学生,在同一个组的学生经常会接触,也会有新的同学的加入。但是SARS是很容易传染的,只要在改组有一位同学感染SARS,那么该组的所有同学都被认为得了SARS。现在的任务是计算出有多少位学生感染SARS了。假定编号为0的同学是得了SARS的。
思路:容易想到并查集中的集合与点,有许多点集。同一点集的点之间有边,一个点可以在几个点集中,若一个点集中有一个点属于另一个点集,两个点集便合并为同一个点集。
代码:

#include<stdio.h>
#include<string.h>
const int N=30005;
int f[N];
int p[N];
int n,m;
int findroot(int x)//查找x的根节点,路径压缩
{
    if(x==f[x])//如果找到根节点
    {
    	return x;//根节点驾到
	}
	else
	{
		return f[x]=findroot(f[x]);//没找到根节点就接着找找它的上级直到找到根节点
	}
}
int Merge(int root1,int root2)//合并root1和root2的集合(可以比作root1和root2做朋友)
{
	int fx,fy;
	fx=findroot(root1);//fx的老大(或者说是根)是root1
	fy=findroot(root2);//fy的老大(或者说是根)是root2
	if(fx!=fy)
	{
		f[fy]=fx;//打一架,谁赢谁当老大(或者说指定其中一个当根)任意指定所以f[fx]=fy也可以
	}
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    	if(n==0&&m==0)
    	{
    		break;
		}
		int sum=0;
		for(int i=0;i<n;i++)//初始化并查集
		{
			f[i]=i;
		}
		for(int i=0;i<m;i++)
		{
			int k;
			scanf("%d",&k);
			scanf("%d",&p[0]);
			for(int j=1;j<k;j++)
			{
				scanf("%d",&p[j]);
				Merge(p[0],p[j]);//合并集合
			}
		}
		for(int i=0;i<n;i++)
		{
			if(findroot(i)==f[0])
			{
				sum++;//集合数加一
			}
		}
		printf("%d\n",sum);
	}
    return 0;
}


代码二:根据并查集模板改变

#include<stdio.h>
#include<string.h>
const int N=30005;
int f[N];
int p[N];
int n,m;
int findroot(int root)//查找x的根节点,路径压缩
{
    int son,tmp;
    son=root;
    while(root!=f[root])//如果找到根节点
    {
    	root=f[root];//根节点驾到
	}
	while(son!=root)
	{
	    tmp=f[son];
	    f[son]=root;
	    son=tmp;
	}
	return root;
}
int Merge(int root1,int root2)//合并root1和root2的集合(可以比作root1和root2做朋友)
{
	int fx,fy;
	fx=findroot(root1);//fx的老大(或者说是根)是root1
	fy=findroot(root2);//fy的老大(或者说是根)是root2
	if(fx!=fy)
	{
		f[fx]=fy;//打一架,谁赢谁当老大(或者说指定其中一个当根)任意指定所以f[fx]=fy也可以
	}
}
int main()
{
    while(scanf("%d%d",&n,&m)!=EOF)
    {
    	if(n==0&&m==0)
    	{
    		break;
		}
		int sum=0;
		for(int i=0;i<n;i++)//初始化并查集
		{
			f[i]=i;
		}
		for(int i=0;i<m;i++)
		{
			int k;
			scanf("%d",&k);
			scanf("%d",&p[0]);
			for(int j=1;j<k;j++)
			{
				scanf("%d",&p[j]);
				Merge(p[0],p[j]);//合并集合
			}
		}
		for(int i=0;i<n;i++)
		{
			if(findroot(i)==f[0])
			{
				sum++;//集合数加一
			}
		}
		printf("%d\n",sum);
	}
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值