The Suspects POJ - 1611(并查集)

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 53259 Accepted: 25326

Description
Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input
The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output
For each case, output the number of suspects in one line.

Sample Input
100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output
4
1
1

问题链接
POJ - 1611

问题简述
同一个小组的人被认为是艾滋病嫌疑人
假定0患有艾滋病

问题分析
并查集问题,建立树,判断除0外的人是否与0有着共同的根。是则为艾滋病嫌疑人。

并查集模板

  // 查根 ,若当前数字已连接其它根,则返回这个根,未连接则返回自身作为根 
int find_root(int x,int parent[])
{
	int x_root =x;
	while (parent [x_root]!=-1)
	{
		x_root =parent[x_root];
	}
	return x_root;
}
void union_maxn(int x,int y,int parent[],int rank[])
{
	int x_root =find_root(x,parent); 
	int y_root =find_root(y,parent);
	if(x_root ==y_root);//若两者的根相同,则二者在同一棵树上,不作处理 
	else if(rank[x_root]>rank[y_root])//当根不同时,考虑二者根的长度进行拼接(提高搜寻效率)
		parent[y_root]=x_root;
	else if(rank[x_root]<rank[y_root])
		parent[x_root]=y_root;
	else 
	{
		parent[x_root]=y_root;
		rank[y_root]++;
	}
}
int main()
{
	int parent [maxn];
	int rank[maxn];
	int edges[maxn][maxn];//此处为二维数组,需注意数组的范围
	memset(parent,-1,sizeof(parent));//初始化 
	memset(rank,0,sizeof(rank));
	memset(edges,0,sizeof(edges));
	union_maxn(x,y,parent,rank);//需要合并时调用这个函数 
}

我的代码

#include <cstring>
#include <ctime>
#include <iostream>
#include <iomanip>
#include <cmath>
#include <algorithm>
#include <stdio.h>
using namespace std;
#define maxn 30005


int find_root(int x,int parent[])//并查集模板 
{
	int x_root =x;
	while (parent [x_root]!=-1)
	{
		x_root =parent[x_root];
	}
	return x_root;
}
void union_maxn(int x,int y,int parent[],int rank[])
{
	int x_root =find_root(x,parent);
	int y_root =find_root(y,parent);
	if(x_root ==y_root);
	else if(rank[x_root]>rank[y_root])
		parent[y_root]=x_root;
	else if(rank[x_root]<rank[y_root])
		parent[x_root]=y_root;
	else 
	{
		parent[x_root]=y_root;
		rank[y_root]++;
	}
}
int main()
{
	int n,m,k;
	while(scanf("%d %d",&n,&m))
	{
		if(n==0&&m==0)
			break;
		if(n==1)
		{
			printf("%d\n",1);
			continue;
		}
		int e=1,d=0;
		int parent[maxn], rank[maxn], edges[maxn];
		memset(parent,-1,sizeof(parent));
		memset(rank,0,sizeof(rank));
		memset(edges,0,sizeof(edges));
		for(int i=0;i<m;i++)
		{
			scanf("%d",&k);
			for(int j=0;j<k;j++)
			{
				scanf("%d",&edges[j]);
				if(edges[j]==0)//如果0不参与任何小组,则患病的只有0一个人 
					d++;
				if(j>0) //连接两个点 
				{
					int x=edges[j-1];
					int y=edges[j];
					union_maxn(x,y,parent,rank);
				}
			}
		}
		if(d==0)
		{
			printf("%d\n",1);
			continue;
		}
		for (int i = 1; i < n; i++) 
		{
			if (find_root(i,parent) == find_root(0,parent))
				e++;
		}
		printf("%d\n",e);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值