Silver Cow Party(迪杰斯特拉+转置矩阵)

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1…N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
Line 1: Three space-separated integers, respectively: N, M, and X
Lines 2… M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse.
Output
Line 1: One integer: the maximum of time any one cow must walk.
Sample Input
4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3
Sample Output
10
Hint
Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.
题意:一群牛分别从1~n号农场赶往x号农场参加聚会,农场与农场之间的路时单向的,在n个农场之间有m条路,给出 a ,b , t表示从a号农场到b号农场需要t时间。 每头牛都会选择最短的路,问来回路上(i→x+x→i)花费时间最长的牛花费的时间是多少?

在枚举其他农场到x农场的最短时间时,最坏的时间复杂度是O(n^3), 2000ms明显超时,所以我们可以采用转置矩阵,因为路径是单向的 我们可以交换mp[i][j]和mp[j][i]的值,这样枚举过程就变成了x农 场到其他农场的最短时间。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
#include<queue>
#define ll long long
#define INF 0x3f3f3f
using namespace std;
typedef pair<int,int> P;
const int maxn = 2e3+10;
int mp[maxn][maxn];
int dis1[maxn],dis2[maxn];
int vis[maxn];
int n,m,x;
void Dijkstra(int s,int dis[])
{
    for(int i=1; i<=n; i++)
    {
        dis[i] = mp[s][i];
        vis[i] = 0;
    }
    dis[s] = 0;
    vis[s] = 1;
    for(int i=1; i<=n; i++)
    {
        int pre = -1;
        int t = INF;
        for(int j=1; j<=n; j++)
        {
            if(!vis[j]&&dis[j]<t)
            {
                t = dis[j];
                pre = j;
            }
        }
        if(pre==-1)
        break;
        vis[pre] = 1;
        for(int j=1; j<=n; j++)
        {
            if(dis[j]>dis[pre] + mp[pre][j])
            {
                dis[j] = dis[pre] + mp[pre][j];
            }
        }
    }
}

int main()
{
    cin>>n>>m>>x;
    int i,j;
    for(i=1; i<=n; i++)
    {
        for(j=1; j<=n; j++)
        {
            if(i==j)
                mp[i][j] = 0;
            else
                mp[i][j]  =INF;
        }
    }
    for(i=0; i<m; i++)
    {
        int u,v,w;
        scanf("%d%d%d",&u,&v,&w);
        if(mp[u][v]>w)
            mp[u][v] = w;
    }
    Dijkstra(x,dis1);
    for(i=1; i<=n; i++)    //转置矩阵
    {
        for(j=i+1; j<=n; j++)
        {
            int cnt = mp[i][j];
            mp[i][j] = mp[j][i];
            mp[j][i] = cnt;
        }
    }
    Dijkstra(x,dis2);
    int ans = -1;
    for(i=1; i<=n; i++)
    {
        ans = max(ans,dis1[i]+dis2[i]);
    }
    printf("%d\n",ans);
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值