POJ 3080 找出m个串中的最长公共子串 二分+爆搜+set

The Genographic Project is a research partnership between IBM and The National Geographic Society that is analyzing DNA from hundreds of thousands of contributors to map how the Earth was populated. 

As an IBM researcher, you have been tasked with writing a program that will find commonalities amongst given snippets of DNA that can be correlated with individual survey information to identify new genetic markers. 

A DNA base sequence is noted by listing the nitrogen bases in the order in which they are found in the molecule. There are four bases: adenine (A), thymine (T), guanine (G), and cytosine (C). A 6-base DNA sequence could be represented as TAGACC.

Given a set of DNA base sequences, determine the longest series of bases that occurs in all of the sequences.

Input

Input to this problem will begin with a line containing a single integer n indicating the number of datasets. Each dataset consists of the following components:

  • A single positive integer m (2 <= m <= 10) indicating the number of base sequences in this dataset.
  • m lines each containing a single base sequence consisting of 60 bases.

Output

For each dataset in the input, output the longest base subsequence common to all of the given base sequences. If the longest common subsequence is less than three bases in length, display the string "no significant commonalities" instead. If multiple subsequences of the same longest length exist, output only the subsequence that comes first in alphabetical order.

Sample Input

3
2
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
3
GATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATACCAGATA
GATACTAGATACTAGATACTAGATACTAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
GATACCAGATACCAGATACCAGATACCAAAGGAAAGGGAAAAGGGGAAAAAGGGGGAAAA
3
CATCATCATCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCCC
ACATCATCATAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAA
AACATCATCATTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT

Sample Output

no significant commonalities
AGATAC
CATCATCAT

本来想到AC自动机或者后缀数组,可惜现在的我还不会,然后一看m的范围,最大只有10,所以单纯暴力也能过了。

子串最短长度为1,最长为60。

可以用二分的思想,检测第一个字符串的长为mid的子串是否被其他所包含,若是,增大low,否则减小high。当然,一个字符串的子串中可能会有重复,并且题意要求若有相同长度的公共子串时,输出字典序最小的一个,于是考虑用set来存储所有子串,一方面保证了集合元素的不重复,另一方面便是已有的排序,所以我们可以直接对集合枚举,若找到,则必是字典序最小的一个。

代码如下:

#include<cstdio>
#include<cstring>
#include<iostream>
#include<string>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<cmath>
#include<set>
#define ll long long
#define inf 0x3f3f3f3f
#define N 220010
#define M 1000010
#define mod 1000000007
using namespace std;
char a[15][65];
char str1[65];
int main(){
    int T;
    scanf("%d",&T);
    while(T--){
        int n;
        scanf("%d",&n);
        for(int i=0;i<n;i++){
            scanf("%s",a[i]);
        }
        int l=1,h=60;
        string ans="";
        while(l<=h){
            int mid=(l+h)>>1;
            bool flag=false;
            set<string>sk;
            for(int i=0;i<=60-mid;i++){
                strncpy(str1,a[0]+i,mid);
                str1[mid]='\0';
                sk.insert((string)str1);
            }
            for(set<string>::iterator j=sk.begin();j!=sk.end();j++){
                flag=false;
                for(int i=1;i<n;i++)
                    if(!strstr(a[i],(*j).data())){
                        flag=true;
                        break;
                    }
                if(!flag){
                    ans=*j;
                    break;
                }
            }
            if(flag)h=mid-1;
            else l=mid+1;
        }
        if(ans.size()<3)printf("no significant commonalities\n");
        else  cout<<ans<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值