POJ 3468 线段树区间修改与区间和

You have N integers, A1, A2, … , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input
The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, … , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
“C a b c” means adding c to each of Aa, Aa+1, … , Ab. -10000 ≤ c ≤ 10000.
“Q a b” means querying the sum of Aa, Aa+1, … , Ab.

Output
You need to answer all Q commands in order. One answer in a line.

Sample Input
10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output
4
55
9
15

Hint
The sums may exceed the range of 32-bit integers.

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#define LL long long
using namespace std;
LL tree[400000],b[400000];
void A(int root){
    tree[root]=tree[root<<1]+tree[root<<1|1];
}
void B(int l,int r,int root){
    int m=(l+r)>>1;
    tree[root<<1]+=b[root]*(m-l+1);
    tree[root<<1|1]+=b[root]*(r-m);
    b[root<<1]+=b[root];
    b[root<<1|1]+=b[root];
    b[root]=0;
}
void build(int l,int r,int root){
    b[root]=0;
    if(l==r)scanf("%lld",&tree[root]);
    else{
        int m=(l+r)>>1;
        build(l,m,root<<1);
        build(m+1,r,root<<1|1);
        A(root);
    }
}
void update(int x,int y,int z,int l,int r,int root){
    if(x<=l&&r<=y){
        tree[root]+=(r-l+1)*z;
        b[root]+=z;return;
    }
    B(l,r,root);//一开始习惯性的写 if(b[root]>0 WA了好多遍
    int m=(l+r)>>1;
    if(x<=m)update(x,y,z,l,m,root<<1);
    if(y>m)update(x,y,z,m+1,r,root<<1|1);
    A(root);
}
LL query(int x,int y,int l,int r,int root){
    if(x<=l&&r<=y)return tree[root];
    B(l,r,root);
    int m=(l+r)>>1;
    LL sum=0;
    if(x<=m)sum+=query(x,y,l,m,root<<1);
    if(y>m)sum+=query(x,y,m+1,r,root<<1|1);
    return sum;
}
int main(){
    int n,q;
    scanf("%d %d",&n,&q);
    build(1,n,1);
    int x,y,z;
    char c[3];
    while(q--){
        scanf("%s %d %d",c,&x,&y);
        if(c[0]=='Q')printf("%lld\n",query(x,y,1,n,1));
        else {
            scanf("%d",&z);
            update(x,y,z,1,n,1);
        }
    }
    return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值