POJ 1502 MPI Maelstrom(求最短路中的最大值)(dijkstra+邻接表)

BIT has recently taken delivery of their new supercomputer, a 32 processor Apollo Odyssey distributed shared memory machine with a hierarchical communication subsystem. Valentine McKee’s research advisor, Jack Swigert, has asked her to benchmark the new system.
Since the Apollo is a distributed shared memory machine, memory access and communication times are not uniform,'' Valentine told Swigert.Communication is fast between processors that share the same memory subsystem, but it is slower between processors that are not on the same subsystem. Communication between the Apollo and machines in our lab is slower yet.’’

``How is Apollo’s port of the Message Passing Interface (MPI) working out?’’ Swigert asked.

Not so well,'' Valentine replied.To do a broadcast of a message from one processor to all the other n-1 processors, they just do a sequence of n-1 sends. That really serializes things and kills the performance.’’

``Is there anything you can do to fix that?’’

Yes,'' smiled Valentine.There is. Once the first processor has sent the message to another, those two can then send messages to two other hosts at the same time. Then there will be four hosts that can send, and so on.’’

``Ah, so you can do the broadcast as a binary tree!’’

``Not really a binary tree – there are some particular features of our network that we should exploit. The interface cards we have allow each processor to simultaneously send messages to any number of the other processors connected to it. However, the messages don’t necessarily arrive at the destinations at the same time – there is a communication cost involved. In general, we need to take into account the communication costs for each link in our network topologies and plan accordingly to minimize the total time required to do a broadcast.’’

Input
The input will describe the topology of a network connecting n processors. The first line of the input will be n, the number of processors, such that 1 <= n <= 100.
The rest of the input defines an adjacency matrix, A. The adjacency matrix is square and of size n x n. Each of its entries will be either an integer or the character x. The value of A(i,j) indicates the expense of sending a message directly from node i to node j. A value of x for A(i,j) indicates that a message cannot be sent directly from node i to node j.
Note that for a node to send a message to itself does not require network communication, so A(i,i) = 0 for 1 <= i <= n. Also, you may assume that the network is undirected (messages can go in either direction with equal overhead), so that A(i,j) = A(j,i). Thus only the entries on the (strictly) lower triangular portion of A will be supplied.
The input to your program will be the lower triangular section of A. That is, the second line of input will contain one entry, A(2,1). The next line will contain two entries, A(3,1) and A(3,2), and so on.

Output
Your program should output the minimum communication time required to broadcast a message from the first processor to all the other processors.

Sample Input
5
50
30 5
100 20 50
10 x x 10

Sample Output
35

题不难,英语伤不起
题目大意:N个处理器要进行信息传递,处理器i传递信息给自己不需要时间,处理器i与处理器j之间相互传递信息的时间是一样的,不同处理器之间传递信息所需要的时间由一个矩阵的下三角给出。若矩阵对应位置为x,则说明相应的两个处理器之间无法传递信息。求从第一个处理器传递信息到其他所有处理器最少需要多少时间。
一点到其它所有点中最短路的最大值

代码如下:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<queue>
#include<vector>
#define ll long long
#define inf 0x3f3f3f3f
#define N 110
using namespace std;
struct A{
    int to,cost;
    bool operator<(const A n1)const{
        return n1.cost<cost;
    };
}x;
int main(){
    int n;
    char a[N];
    while(scanf("%d",&n)!=EOF){
        priority_queue<A>q;
        vector<A>v[N];
        int vis[N]={0},dis[N];
        fill(dis,dis+N,inf);
        for(int i=2;i<=n;i++){
            for(int j=1;j<i;j++){
                scanf("%s",a);
                if(a[0]!='x'){
                    x.to=j;x.cost=atoi(a);
                    v[i].push_back(x);
                    x.to=i;
                    v[j].push_back(x);
                }
            }
        }
        x.to=1,x.cost=0;
        q.push(x);
        while(!q.empty()){
            x=q.top();q.pop();
            vis[x.to]=1;
            for(int i=0,j=v[x.to].size();i<j;i++){
                A e;
                e.to=v[x.to][i].to;
                if(vis[e.to])continue;
                e.cost=x.cost+v[x.to][i].cost;
                dis[e.to]=min(e.cost,dis[e.to]);
                q.push(e);
            }
        }
        int maxx=0;
        dis[1]=0;
        for(int i=1;i<=n;i++){
            maxx=max(maxx,dis[i]);
        }
        printf("%d\n",maxx);
    }
    return 0;
}

参考:

#include<iostream>
#include<queue>
#include<cstring>
#include<cstdio>
#include<algorithm>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=110;
bool vis[maxn];
char s[maxn];
int dis[maxn],link[maxn][maxn];
queue <int> ss;
int n,ans;
void spfa(){
    for(int i=1;i<=n;i++)
        dis[i]=INF;
    dis[1]=0;
    memset(vis,false,sizeof(vis));
    vis[1]=true;
    ss.push(1);
    while(!ss.empty()){
        int x=ss.front();
        ss.pop();
        vis[x]=false;
        for(int i=1;i<=n;i++){
            if(dis[i]>dis[x]+link[x][i]){
                dis[i]=dis[x]+link[x][i];
                if(!vis[i]){
                    ss.push(i);
                    vis[i]=true;
                }
            }
        }
    }
}
int main(){
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;i++)
            for(int j=1;j<=n;j++)
                link[i][j]=INF;
        for(int i=2;i<=n;i++){
            for(int j=1;j<i;j++){
                scanf("%s",s);
                if(s[0]!='x')
                    link[i][j]=link[j][i]=atoi(s);  
            }
        }
        spfa();
        ans=0;
        for(int i=1;i<=n;i++)
            ans=max(ans,dis[i]);
        cout<<ans<<endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值